{"answers":{"affected":"4 open source packages ship an affected version, including bson. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-4412 in the wild and no public exploit code.","fix":"Upgrade bson to a fixed version for your release line: 1.12.3 or 3.0.4.","what":"CVE-2015-4412 is a critical denial of service vulnerability in n/a, published on 5 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4412 and fix it if it is affected.\n\nWhat it is: CVE-2015-4412 is a critical denial of service vulnerability in n/a, published on 5 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4412 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bson (RubyGems): affected all versions; fixed in 1.12.3\n- bson (RubyGems): affected all versions; fixed in 1.12.3\n- bson (RubyGems): affected from 2.0; fixed in 3.0.4\n- bson (RubyGems): affected from 2.0; fixed in 3.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4412/ (Markdown: https://insights.sbomify.com/CVE-2015-4412/index.md)","id":"CVE-2015-4412","markdown":"https://insights.sbomify.com/CVE-2015-4412/index.md","name":"CVE-2015-4412","record":{"aliases":["GHSA-h6rj-8r3c-9gpj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby BSON library","requires_auth":"none","summary":"Remote attackers can cause denial of service or inject arbitrary data via crafted strings in the Ruby BSON library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bson","vendor":"bson_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"BSON injection vulnerability in the legal? function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"bson is vulnerable to denial of service due to incorrect regex validation","id":"CVE-2015-4412","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":4,"n_references":6,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-4413"},"packages":[{"ecosystem":"RubyGems","fixed":["1.12.3"],"introduced":["0"],"last_affected":[],"package":"bson","purl":null,"source":"GHSA-h6rj-8r3c-9gpj"},{"ecosystem":"RubyGems","fixed":["1.12.3"],"introduced":["0"],"last_affected":[],"package":"bson","purl":"pkg:gem/bson","source":"GHSA-h6rj-8r3c-9gpj"},{"ecosystem":"RubyGems","fixed":["3.0.4"],"introduced":["2.0"],"last_affected":[],"package":"bson","purl":null,"source":"GHSA-h6rj-8r3c-9gpj"},{"ecosystem":"RubyGems","fixed":["3.0.4"],"introduced":["2.0"],"last_affected":[],"package":"bson","purl":"pkg:gem/bson","source":"GHSA-h6rj-8r3c-9gpj"}],"prev":{"headline":"BSON rubygem contains potential denial of service","id":"CVE-2015-4411"},"products":["n/a"],"published":"2018-02-05","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service or inject arbitrary data via crafted strings in the Ruby BSON library.","url":"https://insights.sbomify.com/CVE-2015-4412/"}