# CVE-2015-4412: bson is vulnerable to denial of service due to incorrect regex validation

> Remote attackers can cause denial of service or inject arbitrary data via crafted strings in the Ruby BSON library.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Feb 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-h6rj-8r3c-9gpj

## What is CVE-2015-4412?

CVE-2015-4412 is a critical denial of service vulnerability in n/a, published on 5 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

BSON injection vulnerability in the legal? function in BSON (bson-ruby) gem before 3.0.4 for Ruby allows remote attackers to cause a denial of service (resource consumption) or inject arbitrary data via a crafted string.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2015-4412?

4 open source packages ship an affected version, including bson. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bson` | RubyGems | All versions | 1.12.3 |
| `bson` | RubyGems | All versions | 1.12.3 |
| `bson` | RubyGems | From 2.0 | 3.0.4 |
| `bson` | RubyGems | From 2.0 | 3.0.4 |

Products: Bson Project Bson.

## How do I fix CVE-2015-4412?

Upgrade bson to a fixed version for your release line: 1.12.3 or 3.0.4.

## Is CVE-2015-4412 being exploited?

There is no known exploitation of CVE-2015-4412 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-4412 and fix it if it is affected.

What it is: CVE-2015-4412 is a critical denial of service vulnerability in n/a, published on 5 Feb 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-4412 in the wild and no public exploit code.

Affected packages and fixed versions:
- bson (RubyGems): affected all versions; fixed in 1.12.3
- bson (RubyGems): affected all versions; fixed in 1.12.3
- bson (RubyGems): affected from 2.0; fixed in 3.0.4
- bson (RubyGems): affected from 2.0; fixed in 3.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-4412/ (Markdown: https://insights.sbomify.com/CVE-2015-4412/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-4412
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-4412
- OSV: https://osv.dev/vulnerability/CVE-2015-4412

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-4412/
Summaries are generated and may contain mistakes; the official description above is the record.
