# CVE-2015-4619: Spina gem vulnerable to Cross-site request forgery (CSRF) vulnerability

> Cross-site request forgery in Spina allows attackers to perform unauthorized actions on behalf of authenticated users.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2hxv-mx8x-mcj9

## What is CVE-2015-4619?

CVE-2015-4619 is a high-severity vulnerability in n/a, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site request forgery (CSRF) vulnerability in Spina before commit bfe44f289e336f80b6593032679300c493735e75.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-4619?

2 open source packages ship an affected version, including spina. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `spina` | RubyGems | All versions | 0.6.29 |
| `spina` | RubyGems | All versions | 0.6.29 |

Products: Denkgroot Spina.

## How do I fix CVE-2015-4619?

Upgrade spina to 0.6.29 or later.

## Is CVE-2015-4619 being exploited?

There is no known exploitation of CVE-2015-4619 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-41603](https://insights.sbomify.com/CVE-2024-41603/): Cross-site request forgery in n/a (critical 9.6)
- [CVE-2024-41602](https://insights.sbomify.com/CVE-2024-41602/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2024-7106](https://insights.sbomify.com/CVE-2024-7106/): Spina CMS media_folders cross-site request forgery (medium 6.9)
- [CVE-2024-7065](https://insights.sbomify.com/CVE-2024-7065/): Spina CMS cross-site request forgery (medium 6.9)
- [CVE-2023-3445](https://insights.sbomify.com/CVE-2023-3445/): Cross-site Scripting (XSS) - Stored in spinacms/spina (low 3.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-4619 and fix it if it is affected.

What it is: CVE-2015-4619 is a high-severity vulnerability in n/a, published on 7 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-4619 in the wild and no public exploit code.

Affected packages and fixed versions:
- spina (RubyGems): affected all versions; fixed in 0.6.29
- spina (RubyGems): affected all versions; fixed in 0.6.29

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-4619/ (Markdown: https://insights.sbomify.com/CVE-2015-4619/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-4619
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-4619
- OSV: https://osv.dev/vulnerability/CVE-2015-4619

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-4619/
Summaries are generated and may contain mistakes; the official description above is the record.
