{"answers":{"affected":"It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-4680 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-4680 is a high-severity vulnerability in Suse Linux Enterprise Server, published on 5 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-4680 and fix it if it is affected.\n\nWhat it is: CVE-2015-4680 is a high-severity vulnerability in Suse Linux Enterprise Server, published on 5 Apr 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-4680 in the wild and no public exploit code.\n\nAffected product: Suse Linux Enterprise Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4680/ (Markdown: https://insights.sbomify.com/CVE-2015-4680/index.md)","id":"CVE-2015-4680","markdown":"https://insights.sbomify.com/CVE-2015-4680/index.md","name":"CVE-2015-4680","record":{"aliases":["DEBIAN-CVE-2015-4680","GHSA-58q5-m5pm-jwpv","MGASA-2015-0291","SUSE-SU-2017:0102-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"RADIUS server","requires_auth":"none","summary":"FreeRADIUS fails to properly check revocation of intermediate CA certificates, allowing attackers to bypass certificate validation security controls.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"freeradius","vendor":"freeradius"},{"product":"linux_enterprise_server","vendor":"suse"},{"product":"linux_enterprise_software_development_kit","vendor":"suse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"FreeRADIUS 2.2.x before 2.2.8 and 3.0.x before 3.0.9 does not properly check revocation of intermediate CA certificates.","ecosystems":["SUSE:Linux Enterprise Server 12 SP1","SUSE:Linux Enterprise Server 12 SP2","SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP1","SUSE:Linux Enterprise Software Development Kit 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Security feature bypass in n/a","id":"CVE-2015-4680","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"suse:linux_enterprise_server","products":["suse:linux_enterprise_server","suse:linux_enterprise_software_development_kit"],"type":"security_feature_bypass","year":"2015"},"n_packages":7,"n_references":7,"next":{"headline":"Hardcoded credentials in n/a","id":"CVE-2015-4681"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1","source":"SUSE-SU-2017:0102-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2","source":"SUSE-SU-2017:0102-1"},{"ecosystem":"SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20Raspberry%20Pi%2012%20SP2","source":"SUSE-SU-2017:0102-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2017:0102-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2017:0102-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2017:0102-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["3.0.3-14.1"],"introduced":["0"],"last_affected":[],"package":"freeradius-server","purl":"pkg:rpm/suse/freeradius-server\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2017:0102-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-4679"},"products":["n/a"],"published":"2017-04-05","related":[{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-10979","kev_date_added":null,"published":"2017-07-17"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2017-10984","kev_date_added":null,"published":"2017-07-17"},{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2017-9148","kev_date_added":null,"published":"2017-05-29"},{"cvss_score":8.1,"headline":"Memory corruption in n/a","id":"CVE-2015-8763","kev_date_added":null,"published":"2017-03-27"},{"cvss_score":8.1,"headline":"Memory corruption in n/a","id":"CVE-2015-8764","kev_date_added":null,"published":"2017-03-27"},{"cvss_score":7.8,"headline":"Memory corruption in n/a","id":"CVE-2005-4746","kev_date_added":null,"published":"2006-03-28"},{"cvss_score":7.5,"headline":"Information disclosure in freeradius","id":"CVE-2022-41859","kev_date_added":null,"published":"2023-01-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"FreeRADIUS fails to properly check revocation of intermediate CA certificates, allowing attackers to bypass certificate validation security controls.","url":"https://insights.sbomify.com/CVE-2015-4680/"}