{"answers":{"affected":"3 open source packages ship an affected version, including ipython. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-4706 in the wild and no public exploit code.","fix":"Upgrade ipython to 3.2.0 or later.","what":"CVE-2015-4706 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-4706 and fix it if it is affected.\n\nWhat it is: CVE-2015-4706 is a medium-severity cross-site scripting vulnerability in n/a, published on 21 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-4706 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ipython (PyPI): affected from 3.0.0; fixed in 3.2.0\n- ipython (PyPI): affected from 3.0.0; fixed in 3.2.0\n- ipython (PyPI): affected from 3.0.0; fixed in 3.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-4706/ (Markdown: https://insights.sbomify.com/CVE-2015-4706/index.md)","id":"CVE-2015-4706","markdown":"https://insights.sbomify.com/CVE-2015-4706/index.md","name":"CVE-2015-4706","record":{"aliases":["GHSA-q326-jhw3-699g","PYSEC-2017-45"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"IPython library","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via JSON error messages in IPython, potentially leading to code execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ipython","vendor":"ipython"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in IPython 3.x before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/contents path.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Neutralization of Input During Web Page Generation in IPython","id":"CVE-2015-4706","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2015"},"n_packages":3,"n_references":6,"next":{"headline":"Improper Neutralization of Input During Web Page Generation in IPython","id":"CVE-2015-4707"},"packages":[{"ecosystem":"PyPI","fixed":["3.2.0"],"introduced":["3.0.0"],"last_affected":[],"package":"ipython","purl":null,"source":"GHSA-q326-jhw3-699g"},{"ecosystem":"PyPI","fixed":["3.2.0"],"introduced":["3.0.0"],"last_affected":[],"package":"ipython","purl":"pkg:pypi/ipython","source":"GHSA-q326-jhw3-699g"},{"ecosystem":"PyPI","fixed":["3.2.0"],"introduced":["3.0.0"],"last_affected":[],"package":"ipython","purl":"pkg:pypi/ipython","source":"PYSEC-2017-45"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2015-4704"},"products":["n/a"],"published":"2017-09-21","related":[{"cvss_score":6.1,"headline":"Improper Neutralization of Input During Web Page Generation in IPython","id":"CVE-2015-4707","kev_date_added":null,"published":"2017-09-20"},{"cvss_score":4.5,"headline":"set_term_title command injection in ipython","id":"CVE-2023-24816","kev_date_added":null,"published":"2023-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via JSON error messages in IPython, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2015-4706/"}