# CVE-2015-4707: Improper Neutralization of Input During Web Page Generation in IPython

> Remote attackers can inject arbitrary web script or HTML into IPython notebooks via JSON error messages, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Sep 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-4707, GHSA-66gw-5xpf-gfp5, PYSEC-2017-46

## What is CVE-2015-4707?

CVE-2015-4707 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in IPython before 3.2 allows remote attackers to inject arbitrary web script or HTML via vectors involving JSON error messages and the /api/notebooks path.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2015-4707?

3 open source packages ship an affected version, including ipython. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipython` | PyPI | All versions | 3.2.0 |
| `ipython` | PyPI | All versions | 3.2.0 |
| `ipython` | PyPI | All versions | 3.2.0 |

Products: Ipython Ipython.

## How do I fix CVE-2015-4707?

Upgrade ipython to 3.2.0 or later.

## Is CVE-2015-4707 being exploited?

There is no known exploitation of CVE-2015-4707 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-4706](https://insights.sbomify.com/CVE-2015-4706/): Improper Neutralization of Input During Web Page Generation in IPython (medium 6.1)
- [CVE-2023-24816](https://insights.sbomify.com/CVE-2023-24816/): set_term_title command injection in ipython (medium 4.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-4707 and fix it if it is affected.

What it is: CVE-2015-4707 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-4707 in the wild and no public exploit code.

Affected packages and fixed versions:
- ipython (PyPI): affected all versions; fixed in 3.2.0
- ipython (PyPI): affected all versions; fixed in 3.2.0
- ipython (PyPI): affected all versions; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-4707/ (Markdown: https://insights.sbomify.com/CVE-2015-4707/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-4707
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-4707
- OSV: https://osv.dev/vulnerability/CVE-2015-4707

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-4707/
Summaries are generated and may contain mistakes; the official description above is the record.
