CVE-2015-5143 Django Denial-of-service by filling session store
Remote attackers can cause denial of service in Django by exhausting session storage with unique session keys.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5143?
CVE-2015-5143 is a high-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 14 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The session backends in Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 allows remote attackers to cause a denial of service (session store consumption) via multiple requests with unique session keys.
Weakness: CWE-399
Which versions are affected by CVE-2015-5143?
7 open source packages ship an affected version, including django and Django. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.21, 1.7.9, 1.8.3 |
django PyPI | All versions | 1.4.21 |
django PyPI | From 1.5 | 1.7.9 |
django PyPI | From 1.8 | 1.8.3 |
Django PyPI | All versions | 1.4.21 |
Django PyPI | From 1.5 | 1.7.9 |
1 more packages
Django PyPI | From 1.8 | 1.8.3 |
Linux distribution packages (9)
python-django Red Hat:openstack:5::el6 | All versions | 0:1.6.11-1.el6ost |
python-django-bash-completion Red Hat:openstack:5::el6 | All versions | 0:1.6.11-1.el6ost |
python-django-doc Red Hat:openstack:5::el6 | All versions | 0:1.6.11-1.el6ost |
python-django Red Hat:openstack:5::el7 | All versions | 0:1.6.11-2.el7ost |
python-django-bash-completion Red Hat:openstack:5::el7 | All versions | 0:1.6.11-2.el7ost |
python-django-doc Red Hat:openstack:5::el7 | All versions | 0:1.6.11-2.el7ost |
python-django Red Hat:openstack:6::el7 | All versions | 0:1.6.11-2.el7ost |
python-django-bash-completion Red Hat:openstack:6::el7 | All versions | 0:1.6.11-2.el7ost |
python-django-doc Red Hat:openstack:6::el7 | All versions | 0:1.6.11-2.el7ost |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django, Oracle Solaris.
How do I fix CVE-2015-5143?
Upgrade django to a fixed version for your release line: 1.4.21, 1.7.9 or 1.8.3.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-5143 being exploited?
There is no known exploitation of CVE-2015-5143 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-5143, GHSA-h582-2pch-3xv3, PYSEC-2015-20, RHSA-2015:1678, RHSA-2015:1686, UBUNTU-CVE-2015-5143.