CVE-2015-5144 Django Vulnerable to HTTP Response Splitting Attack
Remote attackers can inject arbitrary headers and conduct HTTP response splitting attacks via crafted input in Django validators.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5144?
CVE-2015-5144 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 14 Jul 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Django before 1.4.21, 1.5.x through 1.6.x, 1.7.x before 1.7.9, and 1.8.x before 1.8.3 uses an incorrect regular expression, which allows remote attackers to inject arbitrary headers and conduct HTTP response splitting attacks via a newline character in an (1) email message to the EmailValidator, a (2) URL to the URLValidator, or unspecified vectors to the (3) validate_ipv4_address or (4) validate_slug validator.
Weakness: CWE-20
Which versions are affected by CVE-2015-5144?
7 open source packages ship an affected version, including django and Django. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.4.21, 1.7.9, 1.8.3 |
django PyPI | All versions | 1.4.21 |
django PyPI | From 1.5 | 1.7.9 |
django PyPI | From 1.8a1 | 1.8.3 |
Django PyPI | All versions | 1.4.21 |
Django PyPI | From 1.5 | 1.7.9 |
1 more packages
Django PyPI | From 1.8a1 | 1.8.3 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django, Oracle Solaris.
How do I fix CVE-2015-5144?
Upgrade django to a fixed version for your release line: 1.4.21, 1.7.9 or 1.8.3.
Is CVE-2015-5144 being exploited?
There is no known exploitation of CVE-2015-5144 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2015-5144, GHSA-q5qw-4364-5hhm, PYSEC-2015-10, UBUNTU-CVE-2015-5144.