CVE-2015-5161 ZendXml and Zend Framework contain XXE and XEE Vulnerabilities

Medium 6.8 Published Updated

Remote attackers can bypass security checks to perform XML external entity and expansion attacks via multibyte characters in specific PHP-FPM environments.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5161?

CVE-2015-5161 is a medium-severity vulnerability in n/a, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.

Which versions are affected by CVE-2015-5161?

10 open source packages ship an affected version, including zendframework/zendframework, zendframework/zendframework1 and zendframework/zendxml. It affects 1 product.

PackageAffectedFixed in
zendframework/zendframework PackagistFrom 1.12.01.12.14
zendframework/zendframework PackagistFrom 1.12.01.12.14
zendframework/zendframework PackagistFrom 2.0.02.4.6
zendframework/zendframework PackagistFrom 2.0.02.4.6
zendframework/zendframework PackagistFrom 2.5.02.5.2
zendframework/zendframework PackagistFrom 2.5.02.5.2
4 more packages
zendframework/zendframework1 PackagistFrom 1.12.01.12.14
zendframework/zendframework1 PackagistFrom 1.12.01.12.14
zendframework/zendxml PackagistFrom 1.0.01.0.1
zendframework/zendxml PackagistFrom 1.0.01.0.1

Products include Zend Zend Framework.

How do I fix CVE-2015-5161?

Upgrade zendframework/zendframework to a fixed version for your release line: 1.12.14, 2.4.6 or 2.5.2.

Is CVE-2015-5161 being exploited?

There is no known exploitation of CVE-2015-5161 in the wild and no public exploit code.

Public exploit code: 2 Exploit-DB entries.

Sources

Also known as DLA-302-1, DSA-3340-1, GHSA-xp8p-9rq5-4wgv, MGASA-2015-0370, MGASA-2015-0371.

Is CVE-2015-5161 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free