# CVE-2015-5161: ZendXml and Zend Framework contain XXE and XEE Vulnerabilities

> Remote attackers can bypass security checks to perform XML external entity and expansion attacks via multibyte characters in specific PHP-FPM environments.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DLA-302-1, DSA-3340-1, GHSA-xp8p-9rq5-4wgv, MGASA-2015-0370, MGASA-2015-0371

## What is CVE-2015-5161?

CVE-2015-5161 is a medium-severity vulnerability in n/a, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Zend_Xml_Security::scan in ZendXml before 1.0.1 and Zend Framework before 1.12.14, 2.x before 2.4.6, and 2.5.x before 2.5.2, when running under PHP-FPM in a threaded environment, allows remote attackers to bypass security checks and conduct XML external entity (XXE) and XML entity expansion (XEE) attacks via multibyte encoded characters.

## Which versions are affected by CVE-2015-5161?

10 open source packages ship an affected version, including zendframework/zendframework, zendframework/zendframework1 and zendframework/zendxml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `zendframework/zendframework` | Packagist | From 1.12.0 | 1.12.14 |
| `zendframework/zendframework` | Packagist | From 1.12.0 | 1.12.14 |
| `zendframework/zendframework` | Packagist | From 2.0.0 | 2.4.6 |
| `zendframework/zendframework` | Packagist | From 2.0.0 | 2.4.6 |
| `zendframework/zendframework` | Packagist | From 2.5.0 | 2.5.2 |
| `zendframework/zendframework` | Packagist | From 2.5.0 | 2.5.2 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.14 |
| `zendframework/zendframework1` | Packagist | From 1.12.0 | 1.12.14 |
| `zendframework/zendxml` | Packagist | From 1.0.0 | 1.0.1 |
| `zendframework/zendxml` | Packagist | From 1.0.0 | 1.0.1 |

Products: Zend Zend Framework.

## How do I fix CVE-2015-5161?

Upgrade zendframework/zendframework to a fixed version for your release line: 1.12.14, 2.4.6 or 2.5.2.

## Is CVE-2015-5161 being exploited?

There is no known exploitation of CVE-2015-5161 in the wild and no public exploit code.

Public exploit code:

- Zend Framework 2.4.2 - PHP FPM XML eXternal Entity Injection (exploitdb)
- eBay Magento 1.9.2.1 - PHP FPM XML eXternal Entity Injection (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2020-29312](https://insights.sbomify.com/CVE-2020-29312/): Deserialization in n/a (critical 9.8)
- [CVE-2015-1555](https://insights.sbomify.com/CVE-2015-1555/): Auth bypass in n/a (critical 9.1)
- [CVE-2015-1786](https://insights.sbomify.com/CVE-2015-1786/): Zend Framework CSRF Vulnerability (high 8.8)
- [CVE-2015-7503](https://insights.sbomify.com/CVE-2015-7503/): Zend Framework Information Disclosure (high 7.5)
- [CVE-2014-2685](https://insights.sbomify.com/CVE-2014-2685/): Auth bypass in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5161 and fix it if it is affected.

What it is: CVE-2015-5161 is a medium-severity vulnerability in n/a, published on 25 Aug 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5161 in the wild and no public exploit code.

Affected packages and fixed versions:
- zendframework/zendframework (Packagist): affected from 1.12.0; fixed in 1.12.14
- zendframework/zendframework (Packagist): affected from 1.12.0; fixed in 1.12.14
- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.4.6
- zendframework/zendframework (Packagist): affected from 2.0.0; fixed in 2.4.6
- zendframework/zendframework (Packagist): affected from 2.5.0; fixed in 2.5.2
- zendframework/zendframework (Packagist): affected from 2.5.0; fixed in 2.5.2
- zendframework/zendframework1 (Packagist): affected from 1.12.0; fixed in 1.12.14
- zendframework/zendframework1 (Packagist): affected from 1.12.0; fixed in 1.12.14
- zendframework/zendxml (Packagist): affected from 1.0.0; fixed in 1.0.1
- zendframework/zendxml (Packagist): affected from 1.0.0; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5161/ (Markdown: https://insights.sbomify.com/CVE-2015-5161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5161
- OSV: https://osv.dev/vulnerability/CVE-2015-5161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5161/
Summaries are generated and may contain mistakes; the official description above is the record.
