# CVE-2015-5162: OpenStack Cinder, Glance, and Nova contain Uncontrolled Resource Consumption

> Attackers can cause denial of service via memory and disk consumption by submitting crafted disk images to OpenStack image parsers.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-5162, GHSA-g2j5-7vgx-6xrx, PYSEC-2026-2412, PYSEC-2026-2491, PYSEC-2026-871, RHSA-2016:2923, RHSA-2016:2991, RHSA-2017:0153, RHSA-2017:0156, RHSA-2017:0165, RHSA-2017:0282, UBUNTU-CVE-2015-5162

## What is CVE-2015-5162?

CVE-2015-5162 is a high-severity denial of service vulnerability in n/a, published on 7 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The image parser in OpenStack Cinder 7.0.2 and 8.0.0 through 8.1.1; Glance before 11.0.1 and 12.0.0; and Nova before 12.0.4 and 13.0.0 does not properly limit qemu-img calls, which might allow attackers to cause a denial of service (memory and disk consumption) via a crafted disk image.

Weakness: CWE-399

## Which versions are affected by CVE-2015-5162?

11 open source packages ship an affected version, including cinder, glance and nova. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cinder` | PyPI | All versions | 7.0.2, 9.0.0 |
| `cinder` | PyPI | All versions | 7.0.2 |
| `cinder` | PyPI | All versions | 7.0.2 |
| `cinder` | PyPI | From 8.0.0 | 9.0.0 |
| `cinder` | PyPI | From 8.0.0 | 9.0.0 |
| `glance` | PyPI | All versions | 14.0.0 |
| `glance` | PyPI | All versions | 14.0.0 |
| `glance` | PyPI | All versions | 14.0.0 |
| `nova` | PyPI | All versions | 12.0.4 |
| `nova` | PyPI | All versions | 12.0.4 |
| `nova` | PyPI | All versions | 12.0.4 |
| `openstack-cinder` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-9.el6ost |
| `openstack-cinder-doc` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-9.el6ost |
| `python-cinder` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-9.el6ost |
| `openstack-cinder` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-9.el7ost |
| `openstack-cinder-doc` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-9.el7ost |
| `python-cinder` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-9.el7ost |
| `openstack-cinder` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.4-11.el7ost |
| `openstack-cinder-doc` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.4-11.el7ost |
| `python-cinder` | Red Hat:openstack:6::el7 | All versions | 0:2014.2.4-11.el7ost |
| `openstack-cinder` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.3-12.el7ost |
| `openstack-cinder-doc` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.3-12.el7ost |
| `openstack-glance` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-3.el7ost |
| `openstack-glance-doc` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.2-3.el7ost |
| `openstack-nova` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-api` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-cells` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-cert` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-common` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-compute` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-conductor` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-console` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-doc` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-network` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-novncproxy` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-objectstore` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-scheduler` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-serialproxy` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `openstack-nova-spicehtml5proxy` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.4-32.el7ost |
| `python-cinder` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.3-12.el7ost |

Products: Openstack Cinder, Openstack Glance, Openstack Nova.

## How do I fix CVE-2015-5162?

Upgrade cinder to a fixed version for your release line: 7.0.2 or 9.0.0.

## Is CVE-2015-5162 being exploited?

There is no known exploitation of CVE-2015-5162 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-32498](https://insights.sbomify.com/CVE-2024-32498/): OpenStack Cinder, Glance, and Nova vulnerable to arbitrary file access (medium 6.5)
- [CVE-2017-15139](https://insights.sbomify.com/CVE-2017-15139/): Information disclosure in openstack-cinder (medium 5.1)
- [CVE-2014-3641](https://insights.sbomify.com/CVE-2014-3641/): OpenStack Cinder Exposure of Sensitive Information to an Unauthorized Actor vulnerability (medium 4.0)
- [CVE-2014-7231](https://insights.sbomify.com/CVE-2014-7231/): OpenStack Oslo utility sensitive information exposure via log files (low 2.1)
- [CVE-2013-4183](https://insights.sbomify.com/CVE-2013-4183/): OpenStack Cinder LVMVolumeDriver does not zero deleted snapshots (low 2.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5162 and fix it if it is affected.

What it is: CVE-2015-5162 is a high-severity denial of service vulnerability in n/a, published on 7 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5162 in the wild and no public exploit code.

Affected packages and fixed versions:
- cinder (PyPI): affected all versions; fixed in 7.0.2, 9.0.0
- cinder (PyPI): affected all versions; fixed in 7.0.2
- cinder (PyPI): affected all versions; fixed in 7.0.2
- cinder (PyPI): affected from 8.0.0; fixed in 9.0.0
- cinder (PyPI): affected from 8.0.0; fixed in 9.0.0
- glance (PyPI): affected all versions; fixed in 14.0.0
- glance (PyPI): affected all versions; fixed in 14.0.0
- glance (PyPI): affected all versions; fixed in 14.0.0
- nova (PyPI): affected all versions; fixed in 12.0.4
- nova (PyPI): affected all versions; fixed in 12.0.4
- nova (PyPI): affected all versions; fixed in 12.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5162/ (Markdown: https://insights.sbomify.com/CVE-2015-5162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5162
- OSV: https://osv.dev/vulnerability/CVE-2015-5162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5162/
Summaries are generated and may contain mistakes; the official description above is the record.
