# CVE-2015-5163: OpenStack Image Service (Glance) allows remote authenticated users to read arbitrary file

> Authenticated users can read arbitrary files via crafted qcow2 images in OpenStack Glance V2 API.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Aug 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-5163, GHSA-q73f-vjc2-3gqf, PYSEC-2015-39, RHSA-2015:1639

## What is CVE-2015-5163?

CVE-2015-5163 is a low-severity path traversal vulnerability in n/a, published on 19 Aug 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The import task action in OpenStack Image Service (Glance) 2015.1.x before 2015.1.2 (kilo), when using the V2 API, allows remote authenticated users to read arbitrary files via a crafted backing file for a qcow2 image.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-5163?

3 open source packages ship an affected version, including glance. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `glance` | PyPI | From 2015.1.0 | 2015.1.2 |
| `glance` | PyPI | From 2015.1.0 | 2015.1.2 |
| `glance` | PyPI | From 2015.1.0 | 2015.1.2 |
| `openstack-glance` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-6.el7ost.1 |
| `openstack-glance-doc` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-6.el7ost.1 |
| `python-glance` | Red Hat:openstack:7::el7 | All versions | 0:2015.1.0-6.el7ost.1 |

Products: Openstack Glance.

## How do I fix CVE-2015-5163?

Upgrade glance to 2015.1.2 or later.

## Is CVE-2015-5163 being exploited?

There is no known exploitation of CVE-2015-5163 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-7200](https://insights.sbomify.com/CVE-2017-7200/): OpenStack Glance Server-Side Request Forgery (SSRF) (medium 5.8)
- [CVE-2015-8234](https://insights.sbomify.com/CVE-2015-8234/): OpenStack Glance Signature Verification Bypass (medium 5.5)
- [CVE-2026-34881](https://insights.sbomify.com/CVE-2026-34881/): OpenStack Glance is affected by Server-Side Request Forgery (SSRF) (medium 5.0)
- [CVE-2016-8611](https://insights.sbomify.com/CVE-2016-8611/): Denial of service in openstack-glance (medium 4.3)
- [CVE-2015-3289](https://insights.sbomify.com/CVE-2015-3289/): Denial of service in n/a (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5163 and fix it if it is affected.

What it is: CVE-2015-5163 is a low-severity path traversal vulnerability in n/a, published on 19 Aug 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5163 in the wild and no public exploit code.

Affected packages and fixed versions:
- glance (PyPI): affected from 2015.1.0; fixed in 2015.1.2
- glance (PyPI): affected from 2015.1.0; fixed in 2015.1.2
- glance (PyPI): affected from 2015.1.0; fixed in 2015.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5163/ (Markdown: https://insights.sbomify.com/CVE-2015-5163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5163
- OSV: https://osv.dev/vulnerability/CVE-2015-5163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5163/
Summaries are generated and may contain mistakes; the official description above is the record.
