{"answers":{"affected":"2 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-5170 in the wild and no public exploit code.","fix":"Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to 2.5.2 or later.","what":"CVE-2015-5170 is a high-severity vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2015-5170 and fix it if it is affected.\n\nWhat it is: CVE-2015-5170 is a high-severity vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2015-5170 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 2.5.2\n- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 2.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5170/ (Markdown: https://insights.sbomify.com/CVE-2015-5170/index.md)","id":"CVE-2015-5170","markdown":"https://insights.sbomify.com/CVE-2015-5170/index.md","name":"CVE-2015-5170","record":{"aliases":["GHSA-mpv3-g527-fqrj"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Cloud Foundry Runtime","requires_auth":"none","summary":"Remote attackers can perform CSRF attacks to log users into arbitrary accounts due to missing CSRF checks in Cloud Foundry Runtime.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cf-release","vendor":"cloudfoundry"},{"product":"cloud_foundry_elastic_runtime","vendor":"pivotal_software"},{"product":"cloud_foundry_uaa","vendor":"pivotal_software"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow remote attackers to conduct cross-site request forgery (CSRF) attacks on PWS and log a user into an arbitrary account by leveraging lack of CSRF checks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cloud Foundry Runtime Cross-Site Request Forgery vulnerability","id":"CVE-2015-5170","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2015"},"n_packages":2,"n_references":2,"next":{"headline":"Cloud Foundry Runtime Insufficient Session Expiration vulnerability","id":"CVE-2015-5171"},"packages":[{"ecosystem":"Maven","fixed":["2.5.2"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":null,"source":"GHSA-mpv3-g527-fqrj"},{"ecosystem":"Maven","fixed":["2.5.2"],"introduced":["0"],"last_affected":[],"package":"org.cloudfoundry.identity:cloudfoundry-identity-server","purl":"pkg:maven/org.cloudfoundry.identity/cloudfoundry-identity-server","source":"GHSA-mpv3-g527-fqrj"}],"prev":{"headline":"Cross-site Scripting in Apache Struts","id":"CVE-2015-5169"},"products":["n/a"],"published":"2017-10-24","related":[{"cvss_score":9.8,"headline":"Cloud Foundry Runtime Insufficient Session Expiration vulnerability","id":"CVE-2015-5171","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":9.8,"headline":"Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password","id":"CVE-2015-5172","kev_date_added":null,"published":"2017-10-24"},{"cvss_score":9.8,"headline":"Auth bypass in Cloud Foundry","id":"CVE-2016-8218","kev_date_added":null,"published":"2017-06-13"},{"cvss_score":9.8,"headline":"Cloud Foundry UAA privilege escalation with user invitations","id":"CVE-2017-4992","kev_date_added":null,"published":"2017-06-13"},{"cvss_score":9.6,"headline":"Information disclosure in n/a","id":"CVE-2016-6658","kev_date_added":null,"published":"2018-03-29"},{"cvss_score":8.8,"headline":"Information disclosure in n/a","id":"CVE-2015-5173","kev_date_added":null,"published":"2017-10-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can perform CSRF attacks to log users into arbitrary accounts due to missing CSRF checks in Cloud Foundry Runtime.","url":"https://insights.sbomify.com/CVE-2015-5170/"}