# CVE-2015-5170: Cloud Foundry Runtime Cross-Site Request Forgery vulnerability

> Remote attackers can perform CSRF attacks to log users into arbitrary accounts due to missing CSRF checks in Cloud Foundry Runtime.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-mpv3-g527-fqrj

## What is CVE-2015-5170?

CVE-2015-5170 is a high-severity vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow remote attackers to conduct cross-site request forgery (CSRF) attacks on PWS and log a user into an arbitrary account by leveraging lack of CSRF checks.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2015-5170?

2 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 2.5.2 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 2.5.2 |

Products: Cloudfoundry Cf-Release, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2015-5170?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to 2.5.2 or later.

## Is CVE-2015-5170 being exploited?

There is no known exploitation of CVE-2015-5170 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-5171](https://insights.sbomify.com/CVE-2015-5171/): Cloud Foundry Runtime Insufficient Session Expiration vulnerability (critical 9.8)
- [CVE-2015-5172](https://insights.sbomify.com/CVE-2015-5172/): Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password (critical 9.8)
- [CVE-2016-8218](https://insights.sbomify.com/CVE-2016-8218/): Auth bypass in Cloud Foundry (critical 9.8)
- [CVE-2017-4992](https://insights.sbomify.com/CVE-2017-4992/): Cloud Foundry UAA privilege escalation with user invitations (critical 9.8)
- [CVE-2016-6658](https://insights.sbomify.com/CVE-2016-6658/): Information disclosure in n/a (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5170 and fix it if it is affected.

What it is: CVE-2015-5170 is a high-severity vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-5170 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 2.5.2
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5170/ (Markdown: https://insights.sbomify.com/CVE-2015-5170/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5170
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5170
- OSV: https://osv.dev/vulnerability/CVE-2015-5170

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5170/
Summaries are generated and may contain mistakes; the official description above is the record.
