# CVE-2015-5172: Cloud Foundry Runtime has Weak Password Recovery Mechanism for Forgotten Password

> Attackers can hijack accounts because password reset links do not expire, allowing unauthorized access to user profiles.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Oct 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-cq6m-74r4-x77g

## What is CVE-2015-5172?

CVE-2015-5172 is a critical vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Cloud Foundry Runtime cf-release before 216, UAA before 2.5.2, and Pivotal Cloud Foundry (PCF) Elastic Runtime before 1.7.0 allow attackers to have unspecified impact by leveraging failure to expire password reset links.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2015-5172?

2 open source packages ship an affected version, including org.cloudfoundry.identity:cloudfoundry-identity-server. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 2.5.2 |
| `org.cloudfoundry.identity:cloudfoundry-identity-server` | Maven | All versions | 2.5.2 |

Products: Cloudfoundry Cf-Release, Pivotal Software Cloud Foundry Elastic Runtime, Pivotal Software Cloud Foundry Uaa.

## How do I fix CVE-2015-5172?

Upgrade org.cloudfoundry.identity:cloudfoundry-identity-server to 2.5.2 or later.

## Is CVE-2015-5172 being exploited?

There is no known exploitation of CVE-2015-5172 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-5171](https://insights.sbomify.com/CVE-2015-5171/): Cloud Foundry Runtime Insufficient Session Expiration vulnerability (critical 9.8)
- [CVE-2016-8218](https://insights.sbomify.com/CVE-2016-8218/): Auth bypass in Cloud Foundry (critical 9.8)
- [CVE-2017-4992](https://insights.sbomify.com/CVE-2017-4992/): Cloud Foundry UAA privilege escalation with user invitations (critical 9.8)
- [CVE-2016-6658](https://insights.sbomify.com/CVE-2016-6658/): Information disclosure in n/a (critical 9.6)
- [CVE-2015-5170](https://insights.sbomify.com/CVE-2015-5170/): Cloud Foundry Runtime Cross-Site Request Forgery vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5172 and fix it if it is affected.

What it is: CVE-2015-5172 is a critical vulnerability in n/a, published on 24 Oct 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5172 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 2.5.2
- org.cloudfoundry.identity:cloudfoundry-identity-server (Maven): affected all versions; fixed in 2.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5172/ (Markdown: https://insights.sbomify.com/CVE-2015-5172/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5172
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5172
- OSV: https://osv.dev/vulnerability/CVE-2015-5172

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5172/
Summaries are generated and may contain mistakes; the official description above is the record.
