CVE-2015-5175 Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks
Remote attackers can cause a denial of service in Apache CXF Fediz application plugins, requiring an upgrade to secure the system.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5175?
CVE-2015-5175 is a high-severity denial of service vulnerability in n/a, published on 7 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service.
Weakness: CWE-20
Which versions are affected by CVE-2015-5175?
8 open source packages ship an affected version, including org.apache.cxf.fediz:fediz-core and org.apache.cxf.fediz:fediz-idp. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.cxf.fediz:fediz-core Maven | All versions | 1.1.3 |
org.apache.cxf.fediz:fediz-core Maven | All versions | 1.1.3 |
org.apache.cxf.fediz:fediz-core Maven | From 1.2 | 1.2.1 |
org.apache.cxf.fediz:fediz-core Maven | From 1.2 | 1.2.1 |
org.apache.cxf.fediz:fediz-idp Maven | All versions | 1.1.3 |
org.apache.cxf.fediz:fediz-idp Maven | All versions | 1.1.3 |
2 more packages
org.apache.cxf.fediz:fediz-idp Maven | From 1.2 | 1.2.1 |
org.apache.cxf.fediz:fediz-idp Maven | From 1.2 | 1.2.1 |
Products include Apache Cxf Fediz.
How do I fix CVE-2015-5175?
Upgrade org.apache.cxf.fediz:fediz-core to a fixed version for your release line: 1.1.3 or 1.2.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2015-5175 being exploited?
There is no known exploitation of CVE-2015-5175 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2016-4464 High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2
- CVE-2017-12631 Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3
- CVE-2017-7661 Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, and org.apache.cxf.fediz:fediz-spring2
- CVE-2017-7662 Cross-Site Request Forgery in Apache CXF Fediz
- CVE-2018-8038 High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3
Sources
Also known as GHSA-3357-829x-m9pr.