{"answers":{"affected":"8 open source packages ship an affected version, including org.apache.cxf.fediz:fediz-core and org.apache.cxf.fediz:fediz-idp. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-5175 in the wild and no public exploit code.","fix":"Upgrade org.apache.cxf.fediz:fediz-core to a fixed version for your release line: 1.1.3 or 1.2.1.","what":"CVE-2015-5175 is a high-severity denial of service vulnerability in n/a, published on 7 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5175 and fix it if it is affected.\n\nWhat it is: CVE-2015-5175 is a high-severity denial of service vulnerability in n/a, published on 7 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5175 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.cxf.fediz:fediz-core (Maven): affected all versions; fixed in 1.1.3\n- org.apache.cxf.fediz:fediz-core (Maven): affected all versions; fixed in 1.1.3\n- org.apache.cxf.fediz:fediz-core (Maven): affected from 1.2; fixed in 1.2.1\n- org.apache.cxf.fediz:fediz-core (Maven): affected from 1.2; fixed in 1.2.1\n- org.apache.cxf.fediz:fediz-idp (Maven): affected all versions; fixed in 1.1.3\n- org.apache.cxf.fediz:fediz-idp (Maven): affected all versions; fixed in 1.1.3\n- org.apache.cxf.fediz:fediz-idp (Maven): affected from 1.2; fixed in 1.2.1\n- org.apache.cxf.fediz:fediz-idp (Maven): affected from 1.2; fixed in 1.2.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5175/ (Markdown: https://insights.sbomify.com/CVE-2015-5175/index.md)","id":"CVE-2015-5175","markdown":"https://insights.sbomify.com/CVE-2015-5175/index.md","name":"CVE-2015-5175","record":{"aliases":["GHSA-3357-829x-m9pr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache CXF Fediz","requires_auth":"none","summary":"Remote attackers can cause a denial of service in Apache CXF Fediz application plugins, requiring an upgrade to secure the system.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"cxf_fediz","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Application plugins in Apache CXF Fediz before 1.1.3 and 1.2.x before 1.2.1 allow remote attackers to cause a denial of service.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache CXF Fediz application plugins are vulnerable to Denial of Service (DoS) attacks","id":"CVE-2015-5175","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2015"},"n_packages":8,"n_references":11,"next":{"headline":"Missing authorization in n/a","id":"CVE-2015-5176"},"packages":[{"ecosystem":"Maven","fixed":["1.1.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-core","purl":null,"source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.1.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-core","purl":"pkg:maven/org.apache.cxf.fediz/fediz-core","source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.2.1"],"introduced":["1.2"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-core","purl":null,"source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.2.1"],"introduced":["1.2"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-core","purl":"pkg:maven/org.apache.cxf.fediz/fediz-core","source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.1.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-idp","purl":null,"source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.1.3"],"introduced":["0"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-idp","purl":"pkg:maven/org.apache.cxf.fediz/fediz-idp","source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.2.1"],"introduced":["1.2"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-idp","purl":null,"source":"GHSA-3357-829x-m9pr"},{"ecosystem":"Maven","fixed":["1.2.1"],"introduced":["1.2"],"last_affected":[],"package":"org.apache.cxf.fediz:fediz-idp","purl":"pkg:maven/org.apache.cxf.fediz/fediz-idp","source":"GHSA-3357-829x-m9pr"}],"prev":{"headline":"Improper Limitation of a Pathname to a Restricted Directory in Apache Tomcat","id":"CVE-2015-5174"},"products":["n/a"],"published":"2017-06-07","related":[{"cvss_score":9.8,"headline":"High severity vulnerability that affects org.apache.cxf.fediz:fediz-spring and org.apache.cxf.fediz:fediz-spring2","id":"CVE-2016-4464","kev_date_added":null,"published":"2016-09-21"},{"cvss_score":8.8,"headline":"Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3","id":"CVE-2017-12631","kev_date_added":null,"published":"2017-11-30"},{"cvss_score":8.8,"headline":"Moderate severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, and org.apache.cxf.fediz:fediz-spring2","id":"CVE-2017-7661","kev_date_added":null,"published":"2017-05-16"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery in Apache CXF Fediz","id":"CVE-2017-7662","kev_date_added":null,"published":"2017-05-16"},{"cvss_score":7.5,"headline":"High severity vulnerability that affects org.apache.cxf.fediz:fediz-jetty8, org.apache.cxf.fediz:fediz-jetty9, org.apache.cxf.fediz:fediz-spring, org.apache.cxf.fediz:fediz-spring2, and org.apache.cxf.fediz:fediz-spring3","id":"CVE-2018-8038","kev_date_added":null,"published":"2018-07-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service in Apache CXF Fediz application plugins, requiring an upgrade to secure the system.","url":"https://insights.sbomify.com/CVE-2015-5175/"}