{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-5180 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-5180 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 27 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5180 and fix it if it is affected.\n\nWhat it is: CVE-2015-5180 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 27 Jun 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5180 in the wild and no public exploit code.\n\nAffected product: Canonical Ubuntu Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5180/ (Markdown: https://insights.sbomify.com/CVE-2015-5180/index.md)","id":"CVE-2015-5180","markdown":"https://insights.sbomify.com/CVE-2015-5180/index.md","name":"CVE-2015-5180","record":{"aliases":["DEBIAN-CVE-2015-5180","GHSA-g46c-xfm8-qq3g","SUSE-SU-2019:1716-1","UBUNTU-CVE-2015-5180","USN-3239-2"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"glibc DNS resolver","requires_auth":"none","summary":"Remote attackers can cause a denial of service via NULL pointer dereference in the glibc DNS resolver, affecting Linux distributions.","user_interaction":"not_required","vuln_class":"null_dereference"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"glibc","vendor":"gnu"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-476","name":"NULL Pointer Dereference"}],"description":"res_query in libresolv in glibc before 2.25 allows remote attackers to cause a denial of service (NULL pointer dereference and process crash).","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP4","SUSE:Linux Enterprise Server 12 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP4"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Null dereference in n/a","id":"CVE-2015-5180","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","gnu:glibc"],"type":"null_dereference","year":"2015"},"n_packages":4,"n_references":11,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-5181"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP4","fixed":["2.22-100.15.4"],"introduced":["0"],"last_affected":[],"package":"glibc","purl":"pkg:rpm/suse/glibc\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP4","source":"SUSE-SU-2019:1716-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP4","fixed":["2.22-100.15.4"],"introduced":["0"],"last_affected":[],"package":"glibc","purl":"pkg:rpm/suse/glibc\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP4","source":"SUSE-SU-2019:1716-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP4","fixed":["2.22-100.15.4"],"introduced":["0"],"last_affected":[],"package":"glibc","purl":"pkg:rpm/suse/glibc\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP4","source":"SUSE-SU-2019:1716-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP4","fixed":["2.22-100.15.4"],"introduced":["0"],"last_affected":[],"package":"glibc","purl":"pkg:rpm/suse/glibc\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP4","source":"SUSE-SU-2019:1716-1"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2015-5179"},"products":["n/a"],"published":"2017-06-27","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause a denial of service via NULL pointer dereference in the glibc DNS resolver, affecting Linux distributions.","url":"https://insights.sbomify.com/CVE-2015-5180/"}