CVE-2015-5211 Files or Directories Accessible to External Parties in org.springframework:spring-core
Attackers can trick users into downloading malicious batch scripts via reflected file download in Spring Framework, potentially leading to code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-5211?
CVE-2015-5211 is a critical vulnerability in Debian Debian Linux, published on 25 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Under some situations, the Spring Framework 4.2.0 to 4.2.1, 4.0.0 to 4.1.7, 3.2.0 to 3.2.14 and older unsupported versions is vulnerable to a Reflected File Download (RFD) attack. The attack involves a malicious user crafting a URL with a batch script extension that results in the response being downloaded rather than rendered and also includes some input reflected in the response.
Weakness: CWE-552
Which versions are affected by CVE-2015-5211?
6 open source packages ship an affected version, including org.springframework:spring-core. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.springframework:spring-core Maven | All versions | 3.2.15 |
org.springframework:spring-core Maven | All versions | 3.2.15 |
org.springframework:spring-core Maven | From 4.0.0 | 4.1.8 |
org.springframework:spring-core Maven | From 4.0.0 | 4.1.8 |
org.springframework:spring-core Maven | From 4.2.0 | 4.2.2 |
org.springframework:spring-core Maven | From 4.2.0 | 4.2.2 |
Products include Debian Debian Linux, Vmware Spring Framework.
How do I fix CVE-2015-5211?
Upgrade org.springframework:spring-core to a fixed version for your release line: 3.2.15, 4.1.8 or 4.2.2.
Is CVE-2015-5211 being exploited?
There is no known exploitation of CVE-2015-5211 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2015-5211, GHSA-pgf9-h69p-pcgf, MGASA-2015-0426, ROOT-APP-MAVEN-CVE-2015-5211, UBUNTU-CVE-2015-5211.