# CVE-2015-5211: Files or Directories Accessible to External Parties in org.springframework:spring-core

> Attackers can trick users into downloading malicious batch scripts via reflected file download in Spring Framework, potentially leading to code execution.

- **Severity:** Critical 9.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 May 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-5211, GHSA-pgf9-h69p-pcgf, MGASA-2015-0426, ROOT-APP-MAVEN-CVE-2015-5211, UBUNTU-CVE-2015-5211

## What is CVE-2015-5211?

CVE-2015-5211 is a critical vulnerability in Debian Debian Linux, published on 25 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Under some situations, the Spring Framework 4.2.0 to 4.2.1, 4.0.0 to 4.1.7, 3.2.0 to 3.2.14 and older unsupported versions is vulnerable to a Reflected File Download (RFD) attack. The attack involves a malicious user crafting a URL with a batch script extension that results in the response being downloaded rather than rendered and also includes some input reflected in the response.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2015-5211?

6 open source packages ship an affected version, including org.springframework:spring-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.springframework:spring-core` | Maven | All versions | 3.2.15 |
| `org.springframework:spring-core` | Maven | All versions | 3.2.15 |
| `org.springframework:spring-core` | Maven | From 4.0.0 | 4.1.8 |
| `org.springframework:spring-core` | Maven | From 4.0.0 | 4.1.8 |
| `org.springframework:spring-core` | Maven | From 4.2.0 | 4.2.2 |
| `org.springframework:spring-core` | Maven | From 4.2.0 | 4.2.2 |

Products: Debian Debian Linux, Vmware Spring Framework.

## How do I fix CVE-2015-5211?

Upgrade org.springframework:spring-core to a fixed version for your release line: 3.2.15, 4.1.8 or 4.2.2.

## Is CVE-2015-5211 being exploited?

There is no known exploitation of CVE-2015-5211 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5211 and fix it if it is affected.

What it is: CVE-2015-5211 is a critical vulnerability in Debian Debian Linux, published on 25 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-5211 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.springframework:spring-core (Maven): affected all versions; fixed in 3.2.15
- org.springframework:spring-core (Maven): affected all versions; fixed in 3.2.15
- org.springframework:spring-core (Maven): affected from 4.0.0; fixed in 4.1.8
- org.springframework:spring-core (Maven): affected from 4.0.0; fixed in 4.1.8
- org.springframework:spring-core (Maven): affected from 4.2.0; fixed in 4.2.2
- org.springframework:spring-core (Maven): affected from 4.2.0; fixed in 4.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5211/ (Markdown: https://insights.sbomify.com/CVE-2015-5211/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5211
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5211
- OSV: https://osv.dev/vulnerability/CVE-2015-5211

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5211/
Summaries are generated and may contain mistakes; the official description above is the record.
