{"answers":{"affected":"2 open source packages ship an affected version, including ipsilon. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-5217 in the wild and no public exploit code.","fix":"Upgrade ipsilon to 1.2.0 or later.","what":"CVE-2015-5217 is a medium-severity missing authorization vulnerability in n/a, published on 17 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5217 and fix it if it is affected.\n\nWhat it is: CVE-2015-5217 is a medium-severity missing authorization vulnerability in n/a, published on 17 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5217 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ipsilon (PyPI): affected from 0.1.0; fixed in 1.2.0\n- ipsilon (PyPI): affected from 0.1.0; fixed in 1.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5217/ (Markdown: https://insights.sbomify.com/CVE-2015-5217/index.md)","id":"CVE-2015-5217","markdown":"https://insights.sbomify.com/CVE-2015-5217/index.md","name":"CVE-2015-5217","record":{"aliases":["GHSA-6875-ff47-r6p6"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Ipsilon Identity Provider","requires_auth":"low_privilege","summary":"Authenticated users can cause denial of service by creating duplicate SAML2 Service Provider names due to missing permission checks in the admin interface.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ipsilon","vendor":"ipsilon_project"}],"cvss":{"score":4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:S/C:N/I:N/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.1 does not properly check permissions to update the SAML2 Service Provider (SP) owner, which allows remote authenticated users to cause a denial of service via a duplicate SP name.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ipsilon denial of service via a duplicate SP name","id":"CVE-2015-5217","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"missing_authorization","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"Memory corruption in n/a","id":"CVE-2015-5218"},"packages":[{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0.1.0"],"last_affected":[],"package":"ipsilon","purl":null,"source":"GHSA-6875-ff47-r6p6"},{"ecosystem":"PyPI","fixed":["1.2.0"],"introduced":["0.1.0"],"last_affected":[],"package":"ipsilon","purl":"pkg:pypi/ipsilon","source":"GHSA-6875-ff47-r6p6"}],"prev":{"headline":"Cross-site scripting in Ipsilon","id":"CVE-2015-5216"},"products":["n/a"],"published":"2015-11-17","related":[{"cvss_score":9.1,"headline":"Session Fixation in ipsilon","id":"CVE-2016-8638","kev_date_added":null,"published":"2017-07-12"},{"cvss_score":5.5,"headline":"Ipsilon denial of service by deleting a SAML2 Service Provider (SP)","id":"CVE-2015-5301","kev_date_added":null,"published":"2015-11-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can cause denial of service by creating duplicate SAML2 Service Provider names due to missing permission checks in the admin interface.","url":"https://insights.sbomify.com/CVE-2015-5217/"}