# CVE-2015-5240: OpenStack Neutron Race condition vulnerability

> Authenticated users can bypass IP anti-spoofing controls in OpenStack Neutron via a race condition when using specific plugins or APIs.

- **Severity:** Low 3.5 (`AV:N/AC:M/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Oct 2015
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-5240, GHSA-hhpj-6pj7-wpx5, PYSEC-2026-853, RHSA-2015:1909

## What is CVE-2015-5240?

CVE-2015-5240 is a low-severity vulnerability in n/a, published on 27 Oct 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Race condition in OpenStack Neutron before 2014.2.4 and 2015.1 before 2015.1.2, when using the ML2 plugin or the security groups AMQP API, allows remote authenticated users to bypass IP anti-spoofing controls by changing the device owner of a port to start with network: before the security group rules are applied.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2015-5240?

3 open source packages ship an affected version, including neutron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `neutron` | PyPI | All versions | 7.0.0 |
| `neutron` | PyPI | All versions | 7.0.0 |
| `neutron` | PyPI | All versions | 7.0.0 |
| `openstack-neutron` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-bigswitch` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-brocade` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-cisco` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-embrane` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-hyperv` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-ibm` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-mellanox` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-metaplugin` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-midonet` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-ml2` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-nec` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-nuage` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-ofagent` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-oneconvergence-nvsd` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-openvswitch` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-plumgrid` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-ryu` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-vmware` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron-vpn-agent` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `python-neutron` | Red Hat:openstack:5::el6 | All versions | 0:2014.1.5-4.el6ost |
| `openstack-neutron` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-bigswitch` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-brocade` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-cisco` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-embrane` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-hyperv` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-ibm` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-linuxbridge` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-mellanox` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-metaplugin` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-metering-agent` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-midonet` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-ml2` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |
| `openstack-neutron-nec` | Red Hat:openstack:5::el7 | All versions | 0:2014.1.5-4.el7ost |

Products: Openstack Neutron.

## How do I fix CVE-2015-5240?

Upgrade neutron to 7.0.0 or later.

## Is CVE-2015-5240 being exploited?

There is no known exploitation of CVE-2015-5240 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-38598](https://insights.sbomify.com/CVE-2021-38598/): OpenStack Neutron vulnerable to hardware address impersonation (critical 9.1)
- [CVE-2015-8914](https://insights.sbomify.com/CVE-2015-8914/): OpenStack Neutron allows remote attackers to bypass an intended ICMPv6-spoofing protection mechanism (critical 9.1)
- [CVE-2016-5362](https://insights.sbomify.com/CVE-2016-5362/): OpenStack Neutron allows remote attackers to bypass an intended DHCP-spoofing protection mechanism (high 8.2)
- [CVE-2016-5363](https://insights.sbomify.com/CVE-2016-5363/): OpenStack Neutron Intended MAC-spoofing protection mechanism bypass (high 8.2)
- [CVE-2014-3632](https://insights.sbomify.com/CVE-2014-3632/): Privilege escalation in n/a (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5240 and fix it if it is affected.

What it is: CVE-2015-5240 is a low-severity vulnerability in n/a, published on 27 Oct 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5240 in the wild and no public exploit code.

Affected packages and fixed versions:
- neutron (PyPI): affected all versions; fixed in 7.0.0
- neutron (PyPI): affected all versions; fixed in 7.0.0
- neutron (PyPI): affected all versions; fixed in 7.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5240/ (Markdown: https://insights.sbomify.com/CVE-2015-5240/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5240
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5240
- OSV: https://osv.dev/vulnerability/CVE-2015-5240

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5240/
Summaries are generated and may contain mistakes; the official description above is the record.
