# CVE-2015-5241: Moderate severity vulnerability that affects org.apache.juddi:juddi-client

> Attackers can redirect users to malicious sites after logout in Apache jUDDI, potentially facilitating phishing or credential theft.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 May 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-49h4-g8p5-jgq6

## What is CVE-2015-5241?

CVE-2015-5241 is a medium-severity vulnerability in Apache jUDDI, published on 19 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

After logging into the portal, the logout jsp page redirects the browser back to the login page after. It is feasible for malicious users to redirect the browser to an unintended web page in Apache jUDDI 3.1.2, 3.1.3, 3.1.4, and 3.1.5 when utilizing the portlets based user interface also known as 'Pluto', 'jUDDI Portal', 'UDDI Portal' or 'uddi-console'. User session data, credentials, and auth tokens are cleared before the redirect.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2015-5241?

2 open source packages ship an affected version, including org.apache.juddi:juddi-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.juddi:juddi-client` | Maven | From 3.1.2 | 3.2.0 |
| `org.apache.juddi:juddi-client` | Maven | From 3.1.2 | 3.2.0 |

Products: Apache Juddi.

## How do I fix CVE-2015-5241?

Upgrade org.apache.juddi:juddi-client to 3.2.0 or later.

## Is CVE-2015-5241 being exploited?

There is no known exploitation of CVE-2015-5241 in the wild and no public exploit code.

## Other vulnerabilities in Apache jUDDI

- [CVE-2021-37578](https://insights.sbomify.com/CVE-2021-37578/): Remote code execution via RMI (critical 9.8)
- [CVE-2018-1307](https://insights.sbomify.com/CVE-2018-1307/): Apache juddi-client vulnerable to XML External Entity (XXE) (high 8.1)
- [CVE-2009-4267](https://insights.sbomify.com/CVE-2009-4267/): Other in jUDDI (medium 6.5)
- [CVE-2009-1198](https://insights.sbomify.com/CVE-2009-1198/): Cross-site scripting in n/a (medium 6.1)
- [CVE-2009-1197](https://insights.sbomify.com/CVE-2009-1197/): Other in n/a (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5241 and fix it if it is affected.

What it is: CVE-2015-5241 is a medium-severity vulnerability in Apache jUDDI, published on 19 May 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2015-5241 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.juddi:juddi-client (Maven): affected from 3.1.2; fixed in 3.2.0
- org.apache.juddi:juddi-client (Maven): affected from 3.1.2; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5241/ (Markdown: https://insights.sbomify.com/CVE-2015-5241/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5241
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5241
- OSV: https://osv.dev/vulnerability/CVE-2015-5241

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5241/
Summaries are generated and may contain mistakes; the official description above is the record.
