{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 3 products.","exploited":"There is no known exploitation of CVE-2015-5254 in the wild and no public exploit code.","fix":"Upgrade org.apache.activemq:activemq-client to a fixed version for your release line: 5.11.3 or 5.12.2.","what":"CVE-2015-5254 is a critical unsafe deserialization vulnerability in Apache Activemq, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5254 and fix it if it is affected.\n\nWhat it is: CVE-2015-5254 is a critical unsafe deserialization vulnerability in Apache Activemq, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5254 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.3\n- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.3\n- org.apache.activemq:activemq-client (Maven): affected from 5.12.0; fixed in 5.12.2\n- org.apache.activemq:activemq-client (Maven): affected from 5.12.0; fixed in 5.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5254/ (Markdown: https://insights.sbomify.com/CVE-2015-5254/index.md)","id":"CVE-2015-5254","markdown":"https://insights.sbomify.com/CVE-2015-5254/index.md","name":"CVE-2015-5254","record":{"aliases":["DEBIAN-CVE-2015-5254","DSA-3524-1","GHSA-q9hr-3pg4-3jp4","UBUNTU-CVE-2015-5254"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache ActiveMQ","requires_auth":"none","summary":"Remote attackers can execute arbitrary code by sending crafted serialized JMS ObjectMessage objects to the Apache ActiveMQ broker.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"activemq","vendor":"apache"},{"product":"fedora","vendor":"fedoraproject"},{"product":"openshift","vendor":"redhat"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Apache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to execute arbitrary code via a crafted serialized Java Message Service (JMS) ObjectMessage object.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":"2019-08-30","github_poc":5,"max_poc_stars":86,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-04-20T02:38:50Z","kind":"github_poc","ref":"https://github.com/Catherines77/ActiveMQ-EXPtools","stars":86,"title":"Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588)"},{"date":"2019-08-30T06:03:51Z","kind":"github_poc","ref":"https://github.com/jas502n/CVE-2015-5254","stars":15,"title":"ActiveMQ  Deserialization RCE"},{"date":"2020-08-03T05:51:52Z","kind":"github_poc","ref":"https://github.com/Ma1Dong/ActiveMQ_CVE-2015-5254","stars":2,"title":"ActiveMQ_CVE-2015-5254"},{"date":"2024-11-05T14:58:30Z","kind":"github_poc","ref":"https://github.com/guigui237/Exploitation-de-la-vuln-rabilit-CVE-2015-5254-","stars":0,"title":"La vulnérabilité CVE-2015-5254 est une faille de sécurité dans Apache ActiveMQ, un serveur de messages open source largement utilisé pour la communication entre applications. Cette vulnérabilité touche les versions d'ActiveMQ jusqu'à 5.13.0 et réside dans le manque de filtrage sur les données d'entrées JMS ObjectMessage enyoyées "},{"date":"2026-08-31T07:31:50Z","kind":"github_poc","ref":"https://github.com/radsih/activemq-cve-lab","stars":0,"title":"ActiveMQ CVE-2015-5254 模拟靶场 - 用于 CVE 测试评测和 SCA 扫描演示"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Improper Input Validation in Apache ActiveMQ","id":"CVE-2015-5254","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"apache:activemq","products":["apache:activemq","fedoraproject:fedora","redhat:openshift"],"type":"deserialization","year":"2015"},"n_packages":4,"n_references":13,"next":{"headline":"Server-side request forgery in n/a","id":"CVE-2015-5255"},"packages":[{"ecosystem":"Maven","fixed":["5.11.3"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-q9hr-3pg4-3jp4"},{"ecosystem":"Maven","fixed":["5.11.3"],"introduced":["5.0.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-q9hr-3pg4-3jp4"},{"ecosystem":"Maven","fixed":["5.12.2"],"introduced":["5.12.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":null,"source":"GHSA-q9hr-3pg4-3jp4"},{"ecosystem":"Maven","fixed":["5.12.2"],"introduced":["5.12.0"],"last_affected":[],"package":"org.apache.activemq:activemq-client","purl":"pkg:maven/org.apache.activemq/activemq-client","source":"GHSA-q9hr-3pg4-3jp4"}],"prev":{"headline":"Improper Access Control in Apache CXF","id":"CVE-2015-5253"},"products":["n/a"],"published":"2016-01-08","related":[{"cvss_score":10,"headline":"Apache ActiveMQ Deserialization of Untrusted Data","id":"CVE-2023-46604","kev_date_added":"2023-11-02","published":"2023-10-27"},{"cvss_score":9.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2016-3088","kev_date_added":"2022-02-10","published":"2016-06-01"},{"cvss_score":8.8,"headline":"Apache ActiveMQ Improper Input Validation","id":"CVE-2026-34197","kev_date_added":"2026-04-16","published":"2026-04-07"},{"cvss_score":9.8,"headline":"Remote code execution in Apache ActiveMQ","id":"CVE-2020-11998","kev_date_added":null,"published":"2020-09-10"},{"cvss_score":9.8,"headline":"Command Injection in Xstream","id":"CVE-2013-7285","kev_date_added":null,"published":"2019-05-15"},{"cvss_score":9.8,"headline":"Improper Restriction of XML External Entity Reference in Apache ActiveMQ","id":"CVE-2014-3600","kev_date_added":null,"published":"2017-10-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code by sending crafted serialized JMS ObjectMessage objects to the Apache ActiveMQ broker.","url":"https://insights.sbomify.com/CVE-2015-5254/"}