# CVE-2015-5254: Improper Input Validation in Apache ActiveMQ

> Remote attackers can execute arbitrary code by sending crafted serialized JMS ObjectMessage objects to the Apache ActiveMQ broker.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2015-5254, DSA-3524-1, GHSA-q9hr-3pg4-3jp4, UBUNTU-CVE-2015-5254

## What is CVE-2015-5254?

CVE-2015-5254 is a critical unsafe deserialization vulnerability in Apache Activemq, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache ActiveMQ 5.x before 5.13.0 does not restrict the classes that can be serialized in the broker, which allows remote attackers to execute arbitrary code via a crafted serialized Java Message Service (JMS) ObjectMessage object.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2015-5254?

4 open source packages ship an affected version, including org.apache.activemq:activemq-client. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.11.3 |
| `org.apache.activemq:activemq-client` | Maven | From 5.0.0 | 5.11.3 |
| `org.apache.activemq:activemq-client` | Maven | From 5.12.0 | 5.12.2 |
| `org.apache.activemq:activemq-client` | Maven | From 5.12.0 | 5.12.2 |

Products: Apache Activemq, Fedoraproject Fedora, Redhat Openshift.

## How do I fix CVE-2015-5254?

Upgrade org.apache.activemq:activemq-client to a fixed version for your release line: 5.11.3 or 5.12.2.

## Is CVE-2015-5254 being exploited?

There is no known exploitation of CVE-2015-5254 in the wild and no public exploit code.

Public exploit code:

- Apache ActiveMQ漏洞综合利用工具(CVE-2015-5254，CVE-2016-3088，CVE-2022-41678，CVE-2023-46604，CVE-2024-32114，CVE-2026-34197，CVE-2026-40466， CVE-2026-42588) (github_poc): https://github.com/Catherines77/ActiveMQ-EXPtools
- ActiveMQ  Deserialization RCE (github_poc): https://github.com/jas502n/CVE-2015-5254
- ActiveMQ_CVE-2015-5254 (github_poc): https://github.com/Ma1Dong/ActiveMQ_CVE-2015-5254
- La vulnérabilité CVE-2015-5254 est une faille de sécurité dans Apache ActiveMQ, un serveur de messages open source largement utilisé pour la communication entre applications. Cette vulnérabilité touche les versions d'ActiveMQ jusqu'à 5.13.0 et réside dans le manque de filtrage sur les données d'entrées JMS ObjectMessage enyoyées  (github_poc): https://github.com/guigui237/Exploitation-de-la-vuln-rabilit-CVE-2015-5254-
- ActiveMQ CVE-2015-5254 模拟靶场 - 用于 CVE 测试评测和 SCA 扫描演示 (github_poc): https://github.com/radsih/activemq-cve-lab

## Other vulnerabilities in Apache Activemq

- [CVE-2023-46604](https://insights.sbomify.com/CVE-2023-46604/): Apache ActiveMQ Deserialization of Untrusted Data (critical 10.0, exploited in the wild)
- [CVE-2016-3088](https://insights.sbomify.com/CVE-2016-3088/): Apache ActiveMQ Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-34197](https://insights.sbomify.com/CVE-2026-34197/): Apache ActiveMQ Improper Input Validation (high 8.8, exploited in the wild)
- [CVE-2020-11998](https://insights.sbomify.com/CVE-2020-11998/): Remote code execution in Apache ActiveMQ (critical 9.8)
- [CVE-2013-7285](https://insights.sbomify.com/CVE-2013-7285/): Command Injection in Xstream (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5254 and fix it if it is affected.

What it is: CVE-2015-5254 is a critical unsafe deserialization vulnerability in Apache Activemq, published on 8 Jan 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5254 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.3
- org.apache.activemq:activemq-client (Maven): affected from 5.0.0; fixed in 5.11.3
- org.apache.activemq:activemq-client (Maven): affected from 5.12.0; fixed in 5.12.2
- org.apache.activemq:activemq-client (Maven): affected from 5.12.0; fixed in 5.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5254/ (Markdown: https://insights.sbomify.com/CVE-2015-5254/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5254
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5254
- OSV: https://osv.dev/vulnerability/CVE-2015-5254

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5254/
Summaries are generated and may contain mistakes; the official description above is the record.
