CVE-2015-5264 Moodle allows attackers to enter additional answer attempts

Medium 5.4 Published Updated

Authenticated students can bypass access restrictions to submit extra answer attempts in Moodle lessons, undermining assessment integrity.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5264?

CVE-2015-5264 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The lesson module in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to bypass intended access restrictions and enter additional answer attempts by leveraging the student role.

Weakness: CWE-264

Which versions are affected by CVE-2015-5264?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 2.7.02.7.10
moodle/moodle PackagistFrom 2.7.02.7.10
moodle/moodle PackagistFrom 2.8.02.8.8
moodle/moodle PackagistFrom 2.8.02.8.8
moodle/moodle PackagistFrom 2.9.02.9.2
moodle/moodle PackagistFrom 2.9.02.9.2

Products include Moodle Moodle.

How do I fix CVE-2015-5264?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.10, 2.8.8 or 2.9.2.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2015-5264 being exploited?

There is no known exploitation of CVE-2015-5264 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-mm9q-3847-m48x.

Is CVE-2015-5264 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free