CVE-2015-5266 Moodle allows attackers to obtain manager privileges

Medium 6.8 Published Updated

Remote authenticated users can gain manager privileges in Moodle by exploiting incorrect role processing during long-running sync scripts.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5266?

CVE-2015-5266 is a medium-severity vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The enrol_meta_sync function in enrol/meta/locallib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 allows remote authenticated users to obtain manager privileges in opportunistic circumstances by leveraging incorrect role processing during a long-running sync script.

Weakness: CWE-264

Which versions are affected by CVE-2015-5266?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistFrom 2.7.02.7.10
moodle/moodle PackagistFrom 2.7.02.7.10
moodle/moodle PackagistFrom 2.8.02.8.8
moodle/moodle PackagistFrom 2.8.02.8.8
moodle/moodle PackagistFrom 2.9.02.9.2
moodle/moodle PackagistFrom 2.9.02.9.2

Products include Moodle Moodle.

How do I fix CVE-2015-5266?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.10, 2.8.8 or 2.9.2.

Is CVE-2015-5266 being exploited?

There is no known exploitation of CVE-2015-5266 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-454r-4cjv-vc9h.

Is CVE-2015-5266 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free