CVE-2015-5267 Moodle uses predictable password-recovery tokens

High 7.5 Published Updated

Remote attackers can predict password-recovery tokens due to weak random number generation, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5267?

CVE-2015-5267 is a high-severity vulnerability in Moodle Moodle, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

lib/moodlelib.php in Moodle through 2.6.11, 2.7.x before 2.7.10, 2.8.x before 2.8.8, and 2.9.x before 2.9.2 relies on the PHP mt_rand function to implement the random_string and complex_random_string functions, which makes it easier for remote attackers to predict password-recovery tokens via a brute-force approach.

Weakness: CWE-254, CWE-200

Which versions are affected by CVE-2015-5267?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.7.10
moodle/moodle PackagistAll versions2.7.10
moodle/moodle PackagistFrom 2.8.02.8.8
moodle/moodle PackagistFrom 2.8.02.8.8
moodle/moodle PackagistFrom 2.9.02.9.2
moodle/moodle PackagistFrom 2.9.02.9.2

Products include Moodle Moodle.

How do I fix CVE-2015-5267?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.10, 2.8.8 or 2.9.2.

Is CVE-2015-5267 being exploited?

There is no known exploitation of CVE-2015-5267 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-382v-gxj9-ffhc.

Is CVE-2015-5267 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free