# CVE-2015-5285: Kallithea CRLF injection vulnerability

> Remote attackers can inject HTTP headers and split responses via the login parameter, potentially bypassing security controls.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Oct 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-vfg9-phjp-9frw, PYSEC-2015-13

## What is CVE-2015-5285?

CVE-2015-5285 is a medium-severity vulnerability in n/a, published on 29 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CRLF injection vulnerability in Kallithea before 0.3 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via the came_from parameter to _admin/login.

## Which versions are affected by CVE-2015-5285?

3 open source packages ship an affected version, including kallithea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `kallithea` | PyPI | All versions | 0.3 |
| `kallithea` | PyPI | All versions | 0.3 |
| `kallithea` | PyPI | All versions | 0.3 |

Products: Kallithea-Scm Kallithea.

## How do I fix CVE-2015-5285?

Upgrade kallithea to 0.3 or later.

## Is CVE-2015-5285 being exploited?

There is no known exploitation of CVE-2015-5285 in the wild and no public exploit code.

Public exploit code:

- Kallithea 0.2.9 - 'came_from' HTTP Response Splitting (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2015-0276](https://insights.sbomify.com/CVE-2015-0276/): Kallithea cross-site request forgery (CSRF) vulnerability (high 8.8)
- [CVE-2016-3691](https://insights.sbomify.com/CVE-2016-3691/): Kallithea Routes CSRF Bypass (high 8.8)
- [CVE-2015-1864](https://insights.sbomify.com/CVE-2015-1864/): Kallithea cross-site scripting (XSS) vulnerability (medium 5.4)
- [CVE-2015-0260](https://insights.sbomify.com/CVE-2015-0260/): RhodeCode and Kallithea are vulnerable to sensitive information disclosure (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5285 and fix it if it is affected.

What it is: CVE-2015-5285 is a medium-severity vulnerability in n/a, published on 29 Oct 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5285 in the wild and no public exploit code.

Affected packages and fixed versions:
- kallithea (PyPI): affected all versions; fixed in 0.3
- kallithea (PyPI): affected all versions; fixed in 0.3
- kallithea (PyPI): affected all versions; fixed in 0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5285/ (Markdown: https://insights.sbomify.com/CVE-2015-5285/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5285
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5285
- OSV: https://osv.dev/vulnerability/CVE-2015-5285

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5285/
Summaries are generated and may contain mistakes; the official description above is the record.
