# CVE-2015-5298: Jenkins Google Login Plugin 1.0 and 1.1 allows anonymous users to authenticate through client-side request modification

> Attackers can bypass domain restrictions in the Jenkins Google Login Plugin to authenticate against locked-down instances via client-side request modification.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2022
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-p487-39h9-hm84

## What is CVE-2015-5298?

CVE-2015-5298 is a medium-severity authentication bypass vulnerability in Jenkins Google Login Plugin, published on 7 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The Google Login Plugin (versions 1.0 and 1.1) allows malicious anonymous users to authenticate successfully against Jenkins instances that are supposed to be locked down to a particular Google Apps domain through client-side request modification.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2015-5298?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:google-login. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:google-login` | Maven | From 1.0 | 1.2 |
| `org.jenkins-ci.plugins:google-login` | Maven | From 1.0 | 1.2 |

Products: Jenkins Google Login.

## How do I fix CVE-2015-5298?

Upgrade org.jenkins-ci.plugins:google-login to 1.2 or later.

## Is CVE-2015-5298 being exploited?

There is no known exploitation of CVE-2015-5298 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Google Login Plugin

- [CVE-2023-41936](https://insights.sbomify.com/CVE-2023-41936/): Jenkins Google Login Plugin non-constant time token comparison (high 7.5)
- [CVE-2022-46683](https://insights.sbomify.com/CVE-2022-46683/): Jenkins Google Login Plugin Open Redirect vulnerability (medium 6.1)
- [CVE-2018-1000174](https://insights.sbomify.com/CVE-2018-1000174/): Jenkins Google Login Plugin Open Redirect vulnerability (medium 6.1)
- [CVE-2018-1000173](https://insights.sbomify.com/CVE-2018-1000173/): Jenkins Google Login Plugin Session Fixation vulnerability (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5298 and fix it if it is affected.

What it is: CVE-2015-5298 is a medium-severity authentication bypass vulnerability in Jenkins Google Login Plugin, published on 7 Jul 2022. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5298 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:google-login (Maven): affected from 1.0; fixed in 1.2
- org.jenkins-ci.plugins:google-login (Maven): affected from 1.0; fixed in 1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5298/ (Markdown: https://insights.sbomify.com/CVE-2015-5298/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5298
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5298
- OSV: https://osv.dev/vulnerability/CVE-2015-5298

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5298/
Summaries are generated and may contain mistakes; the official description above is the record.
