CVE-2015-5301 Ipsilon denial of service by deleting a SAML2 Service Provider (SP)
Remote authenticated users can delete SAML2 Service Providers due to missing permission checks, causing denial of service.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5301?
CVE-2015-5301 is a medium-severity missing authorization vulnerability in n/a, published on 17 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
providers/saml2/admin.py in the Identity Provider (IdP) server in Ipsilon 0.1.0 before 1.0.2 and 1.1.x before 1.1.1 does not properly check permissions, which allows remote authenticated users to cause a denial of service by deleting a SAML2 Service Provider (SP).
Weakness: CWE-264
Which versions are affected by CVE-2015-5301?
4 open source packages ship an affected version, including ipsilon. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
ipsilon PyPI | From 0.1.0 | 1.0.2 |
ipsilon PyPI | From 0.1.0 | 1.0.2 |
ipsilon PyPI | From 1.1.0 | 1.2.0 |
ipsilon PyPI | From 1.1.0 | 1.2.0 |
Products include Ipsilon Project Ipsilon.
How do I fix CVE-2015-5301?
Upgrade ipsilon to a fixed version for your release line: 1.0.2 or 1.2.0.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2015-5301 being exploited?
There is no known exploitation of CVE-2015-5301 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-9qp4-79q8-58pr.