# CVE-2015-5305: Directory Traversal in Kubernetes

> Attackers can write to arbitrary files in Kubernetes clusters via crafted object names, potentially compromising node integrity.

- **Severity:** Medium 6.4 (`AV:N/AC:L/Au:N/C:N/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2015
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jp32-vmm6-3vf5, GO-2022-0701, RHSA-2015:1945

## What is CVE-2015-5305?

CVE-2015-5305 is a medium-severity path traversal vulnerability in Redhat Openshift, published on 6 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Directory traversal vulnerability in Kubernetes, as used in Red Hat OpenShift Enterprise 3.0, allows attackers to write to arbitrary files via a crafted object type name, which is not properly handled before passing it to etcd.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2015-5305?

5 open source packages ship an affected version, including k8s.io/kubernetes and github.com/kubernetes/kubernetes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/kubernetes` | Go | All versions | 1.1.1 |
| `k8s.io/kubernetes` | Go | All versions | 1.1.1 |
| `k8s.io/kubernetes` | Go | All versions | 1.1.1 |
| `github.com/kubernetes/kubernetes` | Go | All versions | 1.1.1 |
| `github.com/kubernetes/kubernetes` | Go | All versions | 1.1.1 |
| `openshift` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.20.656dc3e.el7ose |
| `openshift-clients` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.20.656dc3e.el7ose |
| `openshift-master` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.20.656dc3e.el7ose |
| `openshift-node` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.20.656dc3e.el7ose |
| `openshift-sdn-ovs` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.20.656dc3e.el7ose |
| `tuned-profiles-openshift-node` | Red Hat:openshift:3.0::el7 | All versions | 0:3.0.2.0-0.git.20.656dc3e.el7ose |

Products: Redhat Openshift.

## How do I fix CVE-2015-5305?

Upgrade k8s.io/kubernetes to 1.1.1 or later.

## Is CVE-2015-5305 being exploited?

There is no known exploitation of CVE-2015-5305 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift

- [CVE-2014-3496](https://insights.sbomify.com/CVE-2014-3496/): Command injection in n/a (critical 10.0)
- [CVE-2014-0234](https://insights.sbomify.com/CVE-2014-0234/): Hardcoded credentials in Red Hat OpenShift Enterprise (critical 9.8)
- [CVE-2013-2060](https://insights.sbomify.com/CVE-2013-2060/): Command injection in OpenShift Origin (critical 9.8)
- [CVE-2013-4561](https://insights.sbomify.com/CVE-2013-4561/): Path traversal in openshift-origin-msg-node-mcollective (critical 9.1)
- [CVE-2014-0163](https://insights.sbomify.com/CVE-2014-0163/): Command injection in Openshift (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5305 and fix it if it is affected.

What it is: CVE-2015-5305 is a medium-severity path traversal vulnerability in Redhat Openshift, published on 6 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5305 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/kubernetes (Go): affected all versions; fixed in 1.1.1
- k8s.io/kubernetes (Go): affected all versions; fixed in 1.1.1
- k8s.io/kubernetes (Go): affected all versions; fixed in 1.1.1
- github.com/kubernetes/kubernetes (Go): affected all versions; fixed in 1.1.1
- github.com/kubernetes/kubernetes (Go): affected all versions; fixed in 1.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5305/ (Markdown: https://insights.sbomify.com/CVE-2015-5305/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5305
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5305
- OSV: https://osv.dev/vulnerability/CVE-2015-5305

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5305/
Summaries are generated and may contain mistakes; the official description above is the record.
