CVE-2015-5317 Jenkins User Interface (UI) Information Disclosure

Exploited in the wild High 7.5 Published Updated

Remote attackers can obtain sensitive job and build name information from Jenkins Fingerprints pages via direct requests.

Exploited in the wild
Since 12 May 2023
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5317?

CVE-2015-5317 is a high-severity vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote attackers to obtain sensitive job and build name information via a direct request.

Weakness: CWE-200

Which versions are affected by CVE-2015-5317?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-5317?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638. US federal agencies must fix it by 2 Jun 2023.

Is CVE-2015-5317 being exploited?

Yes. Attackers have exploited CVE-2015-5317 in the wild since at least 12 May 2023.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-8pqx-3rxx-f5pm.

Is CVE-2015-5317 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free