# CVE-2015-5317: Jenkins User Interface (UI) Information Disclosure

> Remote attackers can obtain sensitive job and build name information from Jenkins Fingerprints pages via direct requests.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Yes, since 12 May 2023 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Nov 2015
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-8pqx-3rxx-f5pm

## What is CVE-2015-5317?

CVE-2015-5317 is a high-severity vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Fingerprints pages in Jenkins before 1.638 and LTS before 1.625.2 might allow remote attackers to obtain sensitive job and build name information via a direct request.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2015-5317?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.625.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 1.625.2 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.626 | 1.638 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 1.626 | 1.638 |

Products: Jenkins Jenkins, Redhat Openshift.

## How do I fix CVE-2015-5317?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638. US federal agencies must fix it by 2 Jun 2023.

## Is CVE-2015-5317 being exploited?

Yes. Attackers have exploited CVE-2015-5317 in the wild since at least 12 May 2023.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)
- [CVE-2021-21691](https://insights.sbomify.com/CVE-2021-21691/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5317 and fix it if it is affected.

What it is: CVE-2015-5317 is a high-severity vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2015-5317 in the wild since at least 12 May 2023.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.625.2
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.625.2
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.626; fixed in 1.638
- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.626; fixed in 1.638

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5317/ (Markdown: https://insights.sbomify.com/CVE-2015-5317/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5317
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5317
- OSV: https://osv.dev/vulnerability/CVE-2015-5317

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5317/
Summaries are generated and may contain mistakes; the official description above is the record.
