CVE-2015-5318 Jenkins Vulnerable to Cross-Site Request Forgery (CSRF) Attack

Medium 6.8 Published Updated

Remote attackers can bypass CSRF protection in Jenkins by brute-forcing tokens generated with a public salt, requiring user interaction to execute actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-5318?

CVE-2015-5318 is a medium-severity vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Jenkins before 1.638 and LTS before 1.625.2 uses a publicly accessible salt to generate CSRF protection tokens, which makes it easier for remote attackers to bypass the CSRF protection mechanism via a brute force attack.

Weakness: CWE-352

Which versions are affected by CVE-2015-5318?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-5318?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638.

Is CVE-2015-5318 being exploited?

There is no known exploitation of CVE-2015-5318 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-3wmv-7php-rhg5.

Is CVE-2015-5318 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free