CVE-2015-5320 Jenkins allows Exposure of Sensitive Information to an Unauthorized Actor

Medium 5.0 Published Updated

Remote attackers can bypass JNLP slave authentication to access sensitive information or gain administrative privileges on Jenkins servers.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5320?

CVE-2015-5320 is a medium-severity authentication bypass vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Jenkins before 1.638 and LTS before 1.625.2 do not properly verify the shared secret used in JNLP slave connections, which allows remote attackers to connect as slaves and obtain sensitive information or possibly gain administrative access by leveraging knowledge of the name of a slave.

Weakness: CWE-200

Which versions are affected by CVE-2015-5320?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-5320?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2015-5320 being exploited?

There is no known exploitation of CVE-2015-5320 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-449q-v4j2-5h8p.

Is CVE-2015-5320 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free