CVE-2015-5323 Jenkins allows Administrators to Access API Tokens

Medium 6.5 Published Updated

Remote administrators can exploit API token restrictions to gain elevated privileges and execute arbitrary scripts on the Jenkins server.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5323?

CVE-2015-5323 is a medium-severity vulnerability in Jenkins Jenkins, published on 25 Nov 2015. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Jenkins before 1.638 and LTS before 1.625.2 do not properly restrict access to API tokens which might allow remote administrators to gain privileges and run scripts by using an API token of another user.

Weakness: CWE-264

Which versions are affected by CVE-2015-5323?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-5323?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638.

Is CVE-2015-5323 being exploited?

There is no known exploitation of CVE-2015-5323 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-x4m5-j4x4-4wjg.

Is CVE-2015-5323 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free