CVE-2015-5325 Jenkins allows Bypass of Access Restrictions

High 7.5 Published Updated

Attackers can bypass slave-to-master access restrictions in Jenkins using JNLP slaves, potentially escalating privileges or bypassing security controls.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5325?

CVE-2015-5325 is a high-severity authentication bypass vulnerability in Jenkins Jenkins, published on 25 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slave. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3665.

Weakness: CWE-284

Which versions are affected by CVE-2015-5325?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-5325?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2015-5325 being exploited?

There is no known exploitation of CVE-2015-5325 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-x2q2-8pwq-fr5r.

Is CVE-2015-5325 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free