{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-5325 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638.","what":"CVE-2015-5325 is a high-severity authentication bypass vulnerability in Jenkins Jenkins, published on 25 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5325 and fix it if it is affected.\n\nWhat it is: CVE-2015-5325 is a high-severity authentication bypass vulnerability in Jenkins Jenkins, published on 25 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5325 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.625.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 1.625.2\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.626; fixed in 1.638\n- org.jenkins-ci.main:jenkins-core (Maven): affected from 1.626; fixed in 1.638\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5325/ (Markdown: https://insights.sbomify.com/CVE-2015-5325/index.md)","id":"CVE-2015-5325","markdown":"https://insights.sbomify.com/CVE-2015-5325/index.md","name":"CVE-2015-5325","record":{"aliases":["GHSA-x2q2-8pwq-fr5r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CI server","requires_auth":"low_privilege","summary":"Attackers can bypass slave-to-master access restrictions in Jenkins using JNLP slaves, potentially escalating privileges or bypassing security controls.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"jenkins","vendor":"jenkins"},{"product":"openshift","vendor":"redhat"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-284","name":"Improper Access Control"}],"description":"Jenkins before 1.638 and LTS before 1.625.2 allow attackers to bypass intended slave-to-master access restrictions by leveraging a JNLP slave. NOTE: this vulnerability exists because of an incomplete fix for CVE-2014-3665.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins allows Bypass of Access Restrictions","id":"CVE-2015-5325","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"jenkins:jenkins","products":["jenkins:jenkins","redhat:openshift"],"type":"auth_bypass","year":"2015"},"n_packages":4,"n_references":3,"next":{"headline":"Jenkins allows Cross-Site Scripting (XSS)","id":"CVE-2015-5326"},"packages":[{"ecosystem":"Maven","fixed":["1.625.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-x2q2-8pwq-fr5r"},{"ecosystem":"Maven","fixed":["1.625.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-x2q2-8pwq-fr5r"},{"ecosystem":"Maven","fixed":["1.638"],"introduced":["1.626"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":null,"source":"GHSA-x2q2-8pwq-fr5r"},{"ecosystem":"Maven","fixed":["1.638"],"introduced":["1.626"],"last_affected":[],"package":"org.jenkins-ci.main:jenkins-core","purl":"pkg:maven/org.jenkins-ci.main/jenkins-core","source":"GHSA-x2q2-8pwq-fr5r"}],"prev":{"headline":"Jenkins allows Unauthorized Viewing of Queue API Information","id":"CVE-2015-5324"},"products":["n/a"],"published":"2015-11-25","related":[{"cvss_score":9.8,"headline":"Jenkins Command Line Interface (CLI) Path Traversal","id":"CVE-2024-23897","kev_date_added":"2024-08-19","published":"2024-01-24"},{"cvss_score":9.8,"headline":"Jenkins Stapler Web Framework Deserialization of Untrusted Data","id":"CVE-2018-1000861","kev_date_added":"2022-02-10","published":"2018-12-10"},{"cvss_score":9.8,"headline":"Jenkins Remote Code Execution","id":"CVE-2017-1000353","kev_date_added":"2025-10-02","published":"2018-01-29"},{"cvss_score":7.5,"headline":"Jenkins User Interface (UI) Information Disclosure","id":"CVE-2015-5317","kev_date_added":"2023-05-12","published":"2015-11-25"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21690","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21691","kev_date_added":null,"published":"2021-11-04"},{"cvss_score":9.8,"headline":"Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins","id":"CVE-2021-21692","kev_date_added":null,"published":"2021-11-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass slave-to-master access restrictions in Jenkins using JNLP slaves, potentially escalating privileges or bypassing security controls.","url":"https://insights.sbomify.com/CVE-2015-5325/"}