CVE-2015-5326 Jenkins allows Cross-Site Scripting (XSS)

Medium 4.3 Published Updated

Authenticated users can inject scripts into the Jenkins slave overview page, potentially compromising other users' sessions.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5326?

CVE-2015-5326 is a medium-severity cross-site scripting vulnerability in Jenkins Jenkins, published on 25 Nov 2015. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Cross-site scripting (XSS) vulnerability in the slave overview page in Jenkins before 1.638 and LTS before 1.625.2 allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via the slave offline status message.

Weakness: CWE-79

Which versions are affected by CVE-2015-5326?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenAll versions1.625.2
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638
org.jenkins-ci.main:jenkins-core MavenFrom 1.6261.638

Products include Jenkins Jenkins, Redhat Openshift.

How do I fix CVE-2015-5326?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 1.625.2 or 1.638.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2015-5326 being exploited?

There is no known exploitation of CVE-2015-5326 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-5mwr-jg3r-jv66.

Is CVE-2015-5326 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free