CVE-2015-5335 Moodle cross-site request forgery (CSRF) vulnerability

Medium 4.3 Published Updated

Remote attackers can hijack administrator sessions to send statistics to arbitrary hubs, requiring administrators to upgrade Moodle.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-5335?

CVE-2015-5335 is a medium-severity vulnerability in Moodle Moodle, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site request forgery (CSRF) vulnerability in admin/registration/register.php in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote attackers to hijack the authentication of administrators for requests that send statistics to an arbitrary hub URL.

Weakness: CWE-352, CWE-200

Which versions are affected by CVE-2015-5335?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.7.11
moodle/moodle PackagistAll versions2.7.11
moodle/moodle PackagistFrom 2.8.02.8.9
moodle/moodle PackagistFrom 2.8.02.8.9
moodle/moodle PackagistFrom 2.9.02.9.3
moodle/moodle PackagistFrom 2.9.02.9.3

Products include Moodle Moodle.

How do I fix CVE-2015-5335?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.

Is CVE-2015-5335 being exploited?

There is no known exploitation of CVE-2015-5335 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-hpmv-wvq3-gj27.

Is CVE-2015-5335 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free