CVE-2015-5336 Moodle multiple cross-site scripting (XSS) vulnerabilities
Authenticated users can inject arbitrary scripts via crafted survey answers in Moodle, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-5336?
CVE-2015-5336 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the survey module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allow remote authenticated users to inject arbitrary web script or HTML by leveraging the student role and entering a crafted survey answer.
Weakness: CWE-79
Which versions are affected by CVE-2015-5336?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.7.11 |
moodle/moodle Packagist | All versions | 2.7.11 |
moodle/moodle Packagist | From 2.8.0 | 2.8.9 |
moodle/moodle Packagist | From 2.8.0 | 2.8.9 |
moodle/moodle Packagist | From 2.9.0 | 2.9.3 |
moodle/moodle Packagist | From 2.9.0 | 2.9.3 |
Products include Moodle Moodle.
How do I fix CVE-2015-5336?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-5336 being exploited?
There is no known exploitation of CVE-2015-5336 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-grvw-qq2j-r898.