CVE-2015-5337 Moodle XSS Vulnerability
Remote attackers can execute arbitrary scripts in Moodle via crafted SWF files due to improper Flowplayer restrictions, risking user session hijacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2015-5337?
CVE-2015-5337 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly restrict the availability of Flowplayer, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted .swf file.
Weakness: CWE-79
Which versions are affected by CVE-2015-5337?
8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions to 2.6.11 | None |
moodle/moodle Packagist | All versions to 2.6.11 | None |
moodle/moodle Packagist | From 2.7.0 | 2.7.11 |
moodle/moodle Packagist | From 2.7.0 | 2.7.11 |
moodle/moodle Packagist | From 2.8.0 | 2.8.9 |
moodle/moodle Packagist | From 2.8.0 | 2.8.9 |
2 more packages
moodle/moodle Packagist | From 2.9.0 | 2.9.3 |
moodle/moodle Packagist | From 2.9.0 | 2.9.3 |
Products include Moodle Moodle.
How do I fix CVE-2015-5337?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2015-5337 being exploited?
There is no known exploitation of CVE-2015-5337 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-2hw6-6rgf-726v.