CVE-2015-5338 Moodle multiple cross-site request forgery (CSRF) vulnerabilities

High 8.8 Published Updated

Remote attackers can hijack user authentication in Moodle's lesson module via CSRF, potentially taking over accounts.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2015-5338?

CVE-2015-5338 is a high-severity vulnerability in Moodle Moodle, published on 22 Feb 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in the lesson module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allow remote attackers to hijack the authentication of arbitrary users for requests to (1) mod/lesson/mediafile.php or (2) mod/lesson/view.php.

Weakness: CWE-352

Which versions are affected by CVE-2015-5338?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.7.11
moodle/moodle PackagistAll versions2.7.11
moodle/moodle PackagistFrom 2.8.02.8.9
moodle/moodle PackagistFrom 2.8.02.8.9
moodle/moodle PackagistFrom 2.9.02.9.3
moodle/moodle PackagistFrom 2.9.02.9.3

Products include Moodle Moodle.

How do I fix CVE-2015-5338?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.

Is CVE-2015-5338 being exploited?

There is no known exploitation of CVE-2015-5338 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-v33x-q8gh-4x42.

Is CVE-2015-5338 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free