CVE-2015-5339 Moodle does not properly implement group-based access restrictions
Authenticated users can bypass group restrictions to view sensitive course participant information in Moodle.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2015-5339?
CVE-2015-5339 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
The core_enrol_get_enrolled_users web service in enrol/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly implement group-based access restrictions, which allows remote authenticated users to obtain sensitive course-participant information via a web-service request.
Which versions are affected by CVE-2015-5339?
6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | All versions | 2.7.11 |
moodle/moodle Packagist | All versions | 2.7.11 |
moodle/moodle Packagist | From 2.8.0 | 2.8.9 |
moodle/moodle Packagist | From 2.8.0 | 2.8.9 |
moodle/moodle Packagist | From 2.9.0 | 2.9.3 |
moodle/moodle Packagist | From 2.9.0 | 2.9.3 |
Products include Moodle Moodle.
How do I fix CVE-2015-5339?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2015-5339 being exploited?
There is no known exploitation of CVE-2015-5339 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-gmhr-6f43-7qpj.