{"answers":{"affected":"6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2015-5339 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.","what":"CVE-2015-5339 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5339 and fix it if it is affected.\n\nWhat it is: CVE-2015-5339 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5339 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 2.7.11\n- moodle/moodle (Packagist): affected all versions; fixed in 2.7.11\n- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.9\n- moodle/moodle (Packagist): affected from 2.8.0; fixed in 2.8.9\n- moodle/moodle (Packagist): affected from 2.9.0; fixed in 2.9.3\n- moodle/moodle (Packagist): affected from 2.9.0; fixed in 2.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5339/ (Markdown: https://insights.sbomify.com/CVE-2015-5339/index.md)","id":"CVE-2015-5339","markdown":"https://insights.sbomify.com/CVE-2015-5339/index.md","name":"CVE-2015-5339","record":{"aliases":["GHSA-gmhr-6f43-7qpj"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"low_privilege","summary":"Authenticated users can bypass group restrictions to view sensitive course participant information in Moodle.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-264","name":null},{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"The core_enrol_get_enrolled_users web service in enrol/externallib.php in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 does not properly implement group-based access restrictions, which allows remote authenticated users to obtain sensitive course-participant information via a web-service request.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle does not properly implement group-based access restrictions","id":"CVE-2015-5339","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"missing_authorization","year":"2015"},"n_packages":6,"n_references":2,"next":{"headline":"Moodle sensitive information disclosure","id":"CVE-2015-5340"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.11"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gmhr-6f43-7qpj"},{"ecosystem":"Packagist","fixed":["2.7.11"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gmhr-6f43-7qpj"},{"ecosystem":"Packagist","fixed":["2.8.9"],"introduced":["2.8.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gmhr-6f43-7qpj"},{"ecosystem":"Packagist","fixed":["2.8.9"],"introduced":["2.8.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gmhr-6f43-7qpj"},{"ecosystem":"Packagist","fixed":["2.9.3"],"introduced":["2.9.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-gmhr-6f43-7qpj"},{"ecosystem":"Packagist","fixed":["2.9.3"],"introduced":["2.9.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-gmhr-6f43-7qpj"}],"prev":{"headline":"Moodle multiple cross-site request forgery (CSRF) vulnerabilities","id":"CVE-2015-5338"},"products":["n/a"],"published":"2016-02-22","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can bypass group restrictions to view sensitive course participant information in Moodle.","url":"https://insights.sbomify.com/CVE-2015-5339/"}