CVE-2015-5342 Moodle allows attackers to bypass intended access restrictions

Medium 4.3 Published Updated

Authenticated users can bypass access restrictions to add or delete responses in closed choice activities, requiring an upgrade to Moodle.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5342?

CVE-2015-5342 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 22 Feb 2016. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The choice module in Moodle through 2.6.11, 2.7.x before 2.7.11, 2.8.x before 2.8.9, and 2.9.x before 2.9.3 allows remote authenticated users to bypass intended access restrictions by visiting a URL to add or delete responses in the closed state.

Weakness: CWE-264

Which versions are affected by CVE-2015-5342?

6 open source packages ship an affected version, including moodle/moodle. It affects 1 product.

PackageAffectedFixed in
moodle/moodle PackagistAll versions2.7.11
moodle/moodle PackagistAll versions2.7.11
moodle/moodle PackagistFrom 2.8.02.8.9
moodle/moodle PackagistFrom 2.8.02.8.9
moodle/moodle PackagistFrom 2.9.02.9.3
moodle/moodle PackagistFrom 2.9.02.9.3

Products include Moodle Moodle.

How do I fix CVE-2015-5342?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.11, 2.8.9 or 2.9.3.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2015-5342 being exploited?

There is no known exploitation of CVE-2015-5342 in the wild and no public exploit code.

All Moodle Moodle vulnerabilities

Sources

Also known as GHSA-6xpm-q8x9-j3rw.

Is CVE-2015-5342 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free