{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2015-5343 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2015-5343 is a high-severity vulnerability in Debian Debian Linux, published on 14 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2015-5343 and fix it if it is affected.\n\nWhat it is: CVE-2015-5343 is a high-severity vulnerability in Debian Debian Linux, published on 14 Apr 2016. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2015-5343 in the wild and no public exploit code.\n\nAffected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2015-5343/ (Markdown: https://insights.sbomify.com/CVE-2015-5343/index.md)","id":"CVE-2015-5343","markdown":"https://insights.sbomify.com/CVE-2015-5343/index.md","name":"CVE-2015-5343","record":{"aliases":["DEBIAN-CVE-2015-5343","DSA-3424-1","GHSA-g5xg-c32g-4v99","MGASA-2015-0490","SUSE-SU-2016:0043-1","UBUNTU-CVE-2015-5343"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Subversion server","requires_auth":"low_privilege","summary":"Remote authenticated users can trigger an integer overflow leading to denial of service or arbitrary code execution in Apache Subversion.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"subversion","vendor":"apache"},{"product":"debian_linux","vendor":"debian"}],"cvss":{"score":7.6,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"Integer overflow in util.c in mod_dav_svn in Apache Subversion 1.7.x, 1.8.x before 1.8.15, and 1.9.x before 1.9.3 allows remote authenticated users to cause a denial of service (subversion server crash or memory consumption) and possibly execute arbitrary code via a skel-encoded request body, which triggers an out-of-bounds read and heap-based buffer overflow.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 12","SUSE:Linux Enterprise Software Development Kit 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2015-5343","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"debian:debian_linux","products":["debian:debian_linux"],"type":"integer_overflow","year":"2015"},"n_packages":2,"n_references":4,"next":{"headline":"Camel-xstream component in Apache Camel can allow remote attackers to execute arbitrary commands","id":"CVE-2015-5344"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12","fixed":["1.8.10-18.2"],"introduced":["0"],"last_affected":[],"package":"subversion","purl":"pkg:rpm/suse/subversion\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012","source":"SUSE-SU-2016:0043-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["1.8.10-18.2"],"introduced":["0"],"last_affected":[],"package":"subversion","purl":"pkg:rpm/suse/subversion\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2016:0043-1"}],"prev":{"headline":"Moodle allows attackers to bypass intended access restrictions","id":"CVE-2015-5342"},"products":["n/a"],"published":"2016-04-14","related":[{"cvss_score":9.8,"headline":"A maliciously constructed svn+ssh:// URL would cause Subversion clients before 1.8.19, 1.9.x before 1.9.7, and 1.10.0.x through 1.10.0-alpha","id":"CVE-2017-9800","kev_date_added":null,"published":"2017-08-11"},{"cvss_score":8.8,"headline":"Denial of service in n/a","id":"CVE-2013-4246","kev_date_added":null,"published":"2017-10-30"},{"cvss_score":8.6,"headline":"Integer overflow in n/a","id":"CVE-2015-5259","kev_date_added":null,"published":"2016-01-08"},{"cvss_score":8.2,"headline":"Apache Subversion: Command line argument injection on Windows platforms","id":"CVE-2024-45720","kev_date_added":null,"published":"2024-10-09"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2015-0202","kev_date_added":null,"published":"2015-04-08"},{"cvss_score":7.8,"headline":"Denial of service in n/a","id":"CVE-2013-2112","kev_date_added":null,"published":"2013-07-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote authenticated users can trigger an integer overflow leading to denial of service or arbitrary code execution in Apache Subversion.","url":"https://insights.sbomify.com/CVE-2015-5343/"}