CVE-2015-5344 Camel-xstream component in Apache Camel can allow remote attackers to execute arbitrary commands

Critical 9.8 Published Updated

Remote attackers can execute arbitrary commands via crafted serialized Java objects in HTTP requests to Apache Camel's XStream component.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2015-5344?

CVE-2015-5344 is a critical unsafe deserialization vulnerability in Apache Camel, published on 3 Feb 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

The camel-xstream component in Apache Camel before 2.15.5 and 2.16.x before 2.16.1 allow remote attackers to execute arbitrary commands via a crafted serialized Java object in an HTTP request.

Weakness: CWE-19

Which versions are affected by CVE-2015-5344?

4 open source packages ship an affected version, including org.apache.camel:camel-xstream. It affects 1 product.

PackageAffectedFixed in
org.apache.camel:camel-xstream MavenAll versions2.15.5
org.apache.camel:camel-xstream MavenAll versions2.15.5
org.apache.camel:camel-xstream MavenFrom 2.16.02.16.1
org.apache.camel:camel-xstream MavenFrom 2.16.02.16.1

Products include Apache Camel.

How do I fix CVE-2015-5344?

Upgrade org.apache.camel:camel-xstream to a fixed version for your release line: 2.15.5 or 2.16.1.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2015-5344 being exploited?

There is no known exploitation of CVE-2015-5344 in the wild and no public exploit code.

All Apache Camel vulnerabilities

Sources

Also known as GHSA-gv5f-cjw9-5vxg.

Is CVE-2015-5344 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free