# CVE-2015-5467: Yii2 allows attackers to execute any local .php file via a relative path in the view parameter

> Attackers can execute arbitrary local PHP files via path traversal in the view parameter of the Yii framework.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2023
- **Updated:** 25 Sep 2024
- **Also known as:** GHSA-7cfq-72w2-24q4

## What is CVE-2015-5467?

CVE-2015-5467 is a critical path traversal vulnerability in n/a, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

web\ViewAction in Yii (aka Yii2) 2.x before 2.0.5 allows attackers to execute any local .php file via a relative path in the view parameeter.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2015-5467?

2 open source packages ship an affected version, including yiisoft/yii2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2` | Packagist | From 2.0.0 | 2.0.5 |
| `yiisoft/yii2` | Packagist | From 2.0.0 | 2.0.5 |

Products: Yiiframework Yii.

## How do I fix CVE-2015-5467?

Upgrade yiisoft/yii2 to 2.0.5 or later.

## Is CVE-2015-5467 being exploited?

There is no known exploitation of CVE-2015-5467 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)
- [CVE-2020-15148](https://insights.sbomify.com/CVE-2020-15148/): Unsafe deserialization in Yii 2 (high 8.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2015-5467 and fix it if it is affected.

What it is: CVE-2015-5467 is a critical path traversal vulnerability in n/a, published on 21 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2015-5467 in the wild and no public exploit code.

Affected packages and fixed versions:
- yiisoft/yii2 (Packagist): affected from 2.0.0; fixed in 2.0.5
- yiisoft/yii2 (Packagist): affected from 2.0.0; fixed in 2.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2015-5467/ (Markdown: https://insights.sbomify.com/CVE-2015-5467/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2015-5467
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2015-5467
- OSV: https://osv.dev/vulnerability/CVE-2015-5467

---
From sbomify Insights: https://insights.sbomify.com/CVE-2015-5467/
Summaries are generated and may contain mistakes; the official description above is the record.
